lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Wed, 17 Jul 2019 10:52:05 -0400
From:   Alex Kogan <alex.kogan@...cle.com>
To:     Peter Zijlstra <peterz@...radead.org>
Cc:     linux@...linux.org.uk, mingo@...hat.com, will.deacon@....com,
        arnd@...db.de, longman@...hat.com, linux-arch@...r.kernel.org,
        linux-arm-kernel@...ts.infradead.org, linux-kernel@...r.kernel.org,
        tglx@...utronix.de, bp@...en8.de, hpa@...or.com, x86@...nel.org,
        guohanjun@...wei.com, jglauber@...vell.com,
        steven.sistare@...cle.com, daniel.m.jordan@...cle.com,
        dave.dice@...cle.com, rahul.x.yadav@...cle.com
Subject: Re: [PATCH v3 3/5] locking/qspinlock: Introduce CNA into the slow
 path of qspinlock


> On Jul 17, 2019, at 4:59 AM, Peter Zijlstra <peterz@...radead.org> wrote:
> 
> On Wed, Jul 17, 2019 at 10:39:44AM +0200, Peter Zijlstra wrote:
>> On Tue, Jul 16, 2019 at 08:47:24PM +0200, Peter Zijlstra wrote:
> 
>>> My primary concern was readability; I find the above suggestion much
>>> more readable. Maybe it can be written differently; you'll have to play
>>> around a bit.
>> 
>> static void cna_splice_tail(struct cna_node *cn, struct cna_node *head, struct cna_node *tail)
>> {
>> 	struct cna_node *list;
>> 
>> 	/* remove [head,tail] */
>> 	WRITE_ONCE(cn->mcs.next, tail->mcs.next);
>> 	tail->mcs.next = NULL;
>> 
>> 	/* stick [head,tail] on the secondary list tail */
>> 	if (cn->mcs.locked <= 1) {
>> 		/* create secondary list */
>> 		head->tail = tail;
>> 		cn->mcs.locked = head->encoded_tail;
>> 	} else {
>> 		/* add to tail */
>> 		list = (struct cna_node *)decode_tail(cn->mcs.locked);
>> 		list->tail->next = head;
>> 		list->tail = tail;
>> 	}
>> }
>> 
>> static struct cna_node *cna_find_next(struct mcs_spinlock *node)
>> {
>> 	struct cna_node *cni, *cn = (struct cna_node *)node;
>> 	struct cna_node *head, *tail = NULL;
>> 
>> 	/* find any next lock from 'our' node */
>> 	for (head = cni = (struct cna_node *)READ_ONCE(cn->mcs.next);
>> 	     cni && cni->node != cn->node;
>> 	     tail = cni, cni = (struct cna_node *)READ_ONCE(cni->mcs.next))
>> 		;
> 
> I think we can do away with those READ_ONCE()s, at this point those
> pointers should be stable. But please double check.

I think we can get rid of WRITE_ONCE above and the first READ_ONCE, as the 
“first” next pointer (in the node of the current lock holder) is stable at this
point, and is not read / written concurrently. We do need the second READ_ONCE
as we traverse the list and can come across a next pointer being changed.

— Alex

> 
>> 	/* when found, splice any skipped locks onto the secondary list */
>> 	if (cni && tail)
>> 		cna_splice_tail(cn, head, tail);
>> 
>> 	return cni;
>> }
>> 
>> How's that?

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ