lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 27 Aug 2019 14:21:39 -0600
From:   shuah <shuah@...nel.org>
To:     Brendan Higgins <brendanhiggins@...gle.com>
Cc:     kunit-dev@...glegroups.com, linux-kernel@...r.kernel.org,
        linux-kselftest@...r.kernel.org, frowand.list@...il.com,
        sboyd@...nel.org, Randy Dunlap <rdunlap@...radead.org>,
        Stephen Rothwell <sfr@...b.auug.org.au>,
        shuah <shuah@...nel.org>
Subject: Re: [PATCH v1] kunit: fix failure to build without printk

On 8/27/19 11:49 AM, Brendan Higgins wrote:
> Previously KUnit assumed that printk would always be present, which is
> not a valid assumption to make. Fix that by ifdefing out functions which
> directly depend on printk core functions similar to what dev_printk
> does.
> 
> Reported-by: Randy Dunlap <rdunlap@...radead.org>
> Link: https://lore.kernel.org/linux-kselftest/0352fae9-564f-4a97-715a-fabe016259df@kernel.org/T/#t
> Cc: Stephen Rothwell <sfr@...b.auug.org.au>
> Signed-off-by: Brendan Higgins <brendanhiggins@...gle.com>
> ---
>   include/kunit/test.h |  7 +++++++
>   kunit/test.c         | 41 ++++++++++++++++++++++++-----------------
>   2 files changed, 31 insertions(+), 17 deletions(-)
> 
> diff --git a/include/kunit/test.h b/include/kunit/test.h
> index 8b7eb03d4971..339af5f95c4a 100644
> --- a/include/kunit/test.h
> +++ b/include/kunit/test.h
> @@ -339,9 +339,16 @@ static inline void *kunit_kzalloc(struct kunit *test, size_t size, gfp_t gfp)
>   
>   void kunit_cleanup(struct kunit *test);
>   
> +#ifdef CONFIG_PRINTK

Please make this #if defined(CONFIG_PRINTK)

>   void __printf(3, 4) kunit_printk(const char *level,

Line these two up with const char *level,

>   				 const struct kunit *test,
>   				 const char *fmt, ...);
> +#else
> +static inline void __printf(3, 4) kunit_printk(const char *level,
> +					       const struct kunit *test,
> +					       const char *fmt, ...)

Same here.

> +{}

Either line this up or make it

const char *fmt, ...) { }

It is hard to read the way it is currently indented.

> +#endif
>   
>   /**
>    * kunit_info() - Prints an INFO level message associated with @test.
> diff --git a/kunit/test.c b/kunit/test.c
> index b2ca9b94c353..0aa1caf07a6b 100644
> --- a/kunit/test.c
> +++ b/kunit/test.c
> @@ -16,6 +16,7 @@ static void kunit_set_failure(struct kunit *test)
>   	WRITE_ONCE(test->success, false);
>   }
>   
> +#ifdef CONFIG_PRINTK

Same here - if defined

>   static int kunit_vprintk_emit(int level, const char *fmt, va_list args)
>   {
>   	return vprintk_emit(0, level, NULL, 0, fmt, args);
> @@ -40,6 +41,29 @@ static void kunit_vprintk(const struct kunit *test,
>   	kunit_printk_emit(level[1] - '0', "\t# %s: %pV", test->name, vaf);
>   }
>   
> +void kunit_printk(const char *level,
> +		  const struct kunit *test,
> +		  const char *fmt, ...)

Line the arguments up.

> +{
> +	struct va_format vaf;
> +	va_list args;
> +
> +	va_start(args, fmt);
> +
> +	vaf.fmt = fmt;
> +	vaf.va = &args;
> +
> +	kunit_vprintk(test, level, &vaf);
> +
> +	va_end(args);
> +}
> +#else /* CONFIG_PRINTK */
> +static inline int kunit_printk_emit(int level, const char *fmt, ...)
> +{
> +	return 0;

Is there a reason to not use
> +} > +#endif /* CONFIG_PRINTK */
> +
>   static void kunit_print_tap_version(void)
>   {
>   	static bool kunit_has_printed_tap_version;
> @@ -504,20 +528,3 @@ void kunit_cleanup(struct kunit *test)
>   		kunit_resource_free(test, resource);
>   	}
>   }
> -
> -void kunit_printk(const char *level,
> -		  const struct kunit *test,
> -		  const char *fmt, ...) > -{
> -	struct va_format vaf;
> -	va_list args;
> -
> -	va_start(args, fmt);
> -
> -	vaf.fmt = fmt;
> -	vaf.va = &args;
> -
> -	kunit_vprintk(test, level, &vaf);
> -
> -	va_end(args);
> -}
> 

Okay after reviewing this, I am not sure why you need to do all
this.

Why can't you just change the root function that throws the warn:

  static int kunit_vprintk_emit(int level, const char *fmt, va_list args)
{
         return vprintk_emit(0, level, NULL, 0, fmt, args);
}

You aren'r really doing anything extra here, other than calling
vprintk_emit()

Unless I am missing something, can't you solve this problem by including
printk.h and let it handle the !CONFIG_PRINTK case?

thanks,
-- Shuah

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ