lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 18 Sep 2019 17:21:36 -0400
From:   Mimi Zohar <zohar@...ux.ibm.com>
To:     Prakhar Srivastava <prsriva@...ux.microsoft.com>,
        linux-kernel@...r.kernel.org, linux-arm-kernel@...ts.infradead.org,
        linux-integrity@...r.kernel.org, kexec@...ts.infradead.org
Cc:     arnd@...db.de, jean-philippe@...aro.org, allison@...utok.net,
        kristina.martsenko@....org, yamada.masahiro@...ionext.com,
        duwe@....de, mark.rutland@....com, tglx@...utronix.de,
        takahiro.akashi@...aro.org, james.morse@....org,
        catalin.marinas@....com, sboyd@...nel.org, bauerman@...ux.ibm.com
Subject: Re: [RFC PATCH v1 1/1] Add support for arm64 to carry ima
 measurement log in kexec_file_load

On Wed, 2019-09-18 at 10:15 -0400, Mimi Zohar wrote:

> > +	uint64_t tmp_start, tmp_end;
> > +
> > +	propStart = of_find_property(of_chosen, "linux,ima-kexec-buffer",
> > +				     NULL);
> > +	if (propStart) {
> > +		tmp_start = fdt64_to_cpu(*((const fdt64_t *) propStart));
> > +		ret = of_remove_property(of_chosen, propStart);
> > +		if (!ret) {
> > +			return ret;
> > +		}
> > +
> > +		propEnd = of_find_property(of_chosen,
> > +					   "linux,ima-kexec-buffer-end", NULL);
> > +		if (!propEnd) {
> > +			return -EINVAL;
> > +		}
> > +
> > +		tmp_end = fdt64_to_cpu(*((const fdt64_t *) propEnd));
> > +
> > +		ret = of_remove_property(of_chosen, propEnd);
> > +		if (!ret) {
> > +			return ret;
> > +		}
> 
> There seems to be quite a bit of code duplication in this function and
> in ima_get_kexec_buffer().  It could probably be cleaned up with some
> refactoring.

Sorry, my mistake.  One calls of_get_property(), while the other calls
of_find_property().

Mimi

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ