[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <871rwd2ay8.fsf@morokweng.localdomain>
Date: Thu, 19 Sep 2019 00:59:11 -0300
From: Thiago Jung Bauermann <bauerman@...ux.ibm.com>
To: Mimi Zohar <zohar@...ux.ibm.com>
Cc: Prakhar Srivastava <prsriva@...ux.microsoft.com>,
linux-kernel@...r.kernel.org, linux-arm-kernel@...ts.infradead.org,
linux-integrity@...r.kernel.org, kexec@...ts.infradead.org,
arnd@...db.de, jean-philippe@...aro.org, allison@...utok.net,
kristina.martsenko@....org, yamada.masahiro@...ionext.com,
duwe@....de, mark.rutland@....com, tglx@...utronix.de,
takahiro.akashi@...aro.org, james.morse@....org,
catalin.marinas@....com, sboyd@...nel.org
Subject: Re: [RFC PATCH v1 1/1] Add support for arm64 to carry ima measurement log in kexec_file_load
Mimi Zohar <zohar@...ux.ibm.com> writes:
> On Wed, 2019-09-18 at 10:15 -0400, Mimi Zohar wrote:
>
>> > + uint64_t tmp_start, tmp_end;
>> > +
>> > + propStart = of_find_property(of_chosen, "linux,ima-kexec-buffer",
>> > + NULL);
>> > + if (propStart) {
>> > + tmp_start = fdt64_to_cpu(*((const fdt64_t *) propStart));
>> > + ret = of_remove_property(of_chosen, propStart);
>> > + if (!ret) {
>> > + return ret;
>> > + }
>> > +
>> > + propEnd = of_find_property(of_chosen,
>> > + "linux,ima-kexec-buffer-end", NULL);
>> > + if (!propEnd) {
>> > + return -EINVAL;
>> > + }
>> > +
>> > + tmp_end = fdt64_to_cpu(*((const fdt64_t *) propEnd));
>> > +
>> > + ret = of_remove_property(of_chosen, propEnd);
>> > + if (!ret) {
>> > + return ret;
>> > + }
>>
>> There seems to be quite a bit of code duplication in this function and
>> in ima_get_kexec_buffer(). It could probably be cleaned up with some
>> refactoring.
>
> Sorry, my mistake. One calls of_get_property(), while the other calls
> of_find_property().
of_get_property() is a thin wrapper around of_find_property(), so if
that's the only difference I think they can still be merged.
--
Thiago Jung Bauermann
IBM Linux Technology Center
Powered by blists - more mailing lists