[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20190930201324.GA19526@redhat.com>
Date: Mon, 30 Sep 2019 16:13:24 -0400
From: Mike Snitzer <snitzer@...hat.com>
To: Bart Van Assche <bvanassche@....org>
Cc: "Pavel Begunkov (Silence)" <asml.silence@...il.com>,
Jens Axboe <axboe@...nel.dk>,
Josef Bacik <josef@...icpanda.com>,
Keith Busch <kbusch@...nel.org>,
Christoph Hellwig <hch@....de>,
Sagi Grimberg <sagi@...mberg.me>, linux-block@...r.kernel.org,
linux-kernel@...r.kernel.org, nbd@...er.debian.org,
linux-nvme@...ts.infradead.org
Subject: Re: [PATCH v2 1/1] blk-mq: Inline request status checkers
On Mon, Sep 30 2019 at 3:53pm -0400,
Bart Van Assche <bvanassche@....org> wrote:
> On 9/30/19 12:43 PM, Pavel Begunkov (Silence) wrote:
> > @@ -282,7 +282,7 @@ static bool bt_tags_iter(struct sbitmap *bitmap, unsigned int bitnr, void *data)
> > * test and set the bit before assining ->rqs[].
> > */
> > rq = tags->rqs[bitnr];
> > - if (rq && blk_mq_request_started(rq))
> > + if (rq && blk_mq_rq_state(rq) != MQ_RQ_IDLE)
> > return iter_data->fn(rq, iter_data->data, reserved);
> >
> > return true>
> > @@ -360,7 +360,7 @@ static bool blk_mq_tagset_count_completed_rqs(struct request *rq,
> > {
> > unsigned *count = data;
> >
> > - if (blk_mq_request_completed(rq))
> > + if (blk_mq_rq_state(rq) == MQ_RQ_COMPLETE)
> > (*count)++;
> > return true;
> > }
>
> Changes like the above significantly reduce readability of the code in
> the block layer core. I don't like this. I think this patch is a step
> backwards instead of a step forwards.
I agree, not helpful.
Powered by blists - more mailing lists