[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <6da099e2-7e29-3c7b-7682-df86835e9e8c@gmail.com>
Date: Mon, 30 Sep 2019 23:12:31 +0300
From: Pavel Begunkov <asml.silence@...il.com>
To: Bart Van Assche <bvanassche@....org>, Jens Axboe <axboe@...nel.dk>,
Josef Bacik <josef@...icpanda.com>,
Keith Busch <kbusch@...nel.org>,
Christoph Hellwig <hch@....de>,
Sagi Grimberg <sagi@...mberg.me>, linux-block@...r.kernel.org,
linux-kernel@...r.kernel.org, nbd@...er.debian.org,
linux-nvme@...ts.infradead.org
Subject: Re: [PATCH v2 1/1] blk-mq: Inline request status checkers
On 30/09/2019 22:53, Bart Van Assche wrote:
> On 9/30/19 12:43 PM, Pavel Begunkov (Silence) wrote:
>> @@ -282,7 +282,7 @@ static bool bt_tags_iter(struct sbitmap *bitmap, unsigned int bitnr, void *data)
>> * test and set the bit before assining ->rqs[].
>> */
>> rq = tags->rqs[bitnr];
>> - if (rq && blk_mq_request_started(rq))
>> + if (rq && blk_mq_rq_state(rq) != MQ_RQ_IDLE)
>> return iter_data->fn(rq, iter_data->data, reserved);
>>
>> return true>
>> @@ -360,7 +360,7 @@ static bool blk_mq_tagset_count_completed_rqs(struct request *rq,
>> {
>> unsigned *count = data;
>>
>> - if (blk_mq_request_completed(rq))
>> + if (blk_mq_rq_state(rq) == MQ_RQ_COMPLETE)
>> (*count)++;
>> return true;
>> }
>
> Changes like the above significantly reduce readability of the code in
> the block layer core. I don't like this. I think this patch is a step
> backwards instead of a step forwards.
Yep, looks too bulky.
Jens, could you consider the first version?
--
Yours sincerely,
Pavel Begunkov
Download attachment "signature.asc" of type "application/pgp-signature" (834 bytes)
Powered by blists - more mailing lists