[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20191018163310.GB26319@linux.intel.com>
Date: Fri, 18 Oct 2019 09:33:10 -0700
From: Sean Christopherson <sean.j.christopherson@...el.com>
To: Thomas Hellström (VMware)
<thomas_os@...pmail.org>
Cc: linux-kernel@...r.kernel.org,
Thomas Hellstrom <thellstrom@...are.com>,
Sami Tolvanen <samitolvanen@...gle.com>,
clang-built-linux@...glegroups.com,
"H. Peter Anvin" <hpa@...or.com>, Ingo Molnar <mingo@...hat.com>,
Thomas Gleixner <tglx@...utronix.de>, x86-ml <x86@...nel.org>,
Borislav Petkov <bp@...e.de>
Subject: Re: [PATCH 1/2] x86/cpu/vmware: Use the full form of INL in
VMWARE_HYPERCALL
On Fri, Oct 18, 2019 at 03:40:51PM +0200, Thomas Hellström (VMware) wrote:
> From: Thomas Hellstrom <thellstrom@...are.com>
>
> LLVM's assembler doesn't accept the short form INL instruction:
>
> inl (%%dx)
>
> but instead insists on the output register to be explicitly specified.
>
> This was previously fixed for the VMWARE_PORT macro. Fix it also for
> the VMWARE_HYPERCALL macro.
>
> Fixes: b4dd4f6e3648 ("Add a header file for hypercall definitions")
> Suggested-by: Sami Tolvanen <samitolvanen@...gle.com>
> Signed-off-by: Thomas Hellstrom <thellstrom@...are.com>
> Cc: clang-built-linux@...glegroups.com
> Cc: "H. Peter Anvin" <hpa@...or.com>
> Cc: Ingo Molnar <mingo@...hat.com>
> Cc: Thomas Gleixner <tglx@...utronix.de>
> Cc: x86-ml <x86@...nel.org>
> Cc: Borislav Petkov <bp@...e.de>
> ---
> arch/x86/include/asm/vmware.h | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/arch/x86/include/asm/vmware.h b/arch/x86/include/asm/vmware.h
> index e00c9e875933..f5fbe3778aef 100644
> --- a/arch/x86/include/asm/vmware.h
> +++ b/arch/x86/include/asm/vmware.h
> @@ -29,7 +29,8 @@
>
> /* The low bandwidth call. The low word of edx is presumed clear. */
> #define VMWARE_HYPERCALL \
> - ALTERNATIVE_2("movw $" VMWARE_HYPERVISOR_PORT ", %%dx; inl (%%dx)", \
> + ALTERNATIVE_2("movw $" VMWARE_HYPERVISOR_PORT \
> + ", %%dx; inl (%%dx), %%eax", \
Why wrap in the middle of movw? Wrapping between instructions or letting
the line poke out is more readable IMO, e.g.
ALTERNATIVE_2("movw $" VMWARE_HYPERVISOR_PORT ", %%dx; " \
"inl (%%dx), %%eax", \
or
ALTERNATIVE_2("movw $" VMWARE_HYPERVISOR_PORT ", %%dx; inl (%%dx), %%eax", \
> "vmcall", X86_FEATURE_VMCALL, \
> "vmmcall", X86_FEATURE_VMW_VMMCALL)
>
> --
> 2.21.0
>
Powered by blists - more mailing lists