[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <3bf9fea7-99d3-3a9b-6565-39d62f5ee473@web.de>
Date: Tue, 19 Nov 2019 14:32:55 +0100
From: Markus Elfring <Markus.Elfring@....de>
To: Namjae Jeon <namjae.jeon@...sung.com>,
linux-fsdevel@...r.kernel.org
Cc: linux-kernel@...r.kernel.org, kernel-janitors@...r.kernel.org,
Christoph Hellwig <hch@....de>,
Daniel Wagner <dwagner@...e.de>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Sungjong Seo <sj1557.seo@...sung.com>,
Valdis Klētnieks <valdis.kletnieks@...edu>,
linkinjeon@...il.com
Subject: Re: [PATCH v3 02/13] exfat: add super block operations
…
> +++ b/fs/exfat/super.c
…
> +static int __exfat_fill_super(struct super_block *sb)
> +{
…
> +free_upcase:
> + exfat_free_upcase_table(sb);
Label alternatives?
* free_table
* free_upcase_table
…
> +static int exfat_fill_super(struct super_block *sb, struct fs_context *fc)
> +{
…
> + if (EXFAT_SB(sb)->options.case_sensitive)
> + sb->s_d_op = &exfat_dentry_ops;
> + else
> + sb->s_d_op = &exfat_ci_dentry_ops;
How do you think about the usage of conditional operators at similar places?
+ sb->s_d_op = EXFAT_SB(sb)->options.case_sensitive
+ ? &exfat_dentry_ops;
+ : &exfat_ci_dentry_ops;
…
> +failed_mount3:
> + iput(root_inode);
I find the label “put_inode” more appropriate.
…
> +failed_mount2:
> + exfat_free_upcase_table(sb);
I find the label “free_table” more helpful.
…
> +failed_mount:
> + if (sbi->nls_io)
> + unload_nls(sbi->nls_io);
Can the label “check_nls_io” be nicer?
…
> +static int __init init_exfat_fs(void)
> +{
…
> +shutdown_cache:
> + exfat_cache_shutdown();
> +
> + return err;
Would you like to omit blank lines at similar places?
Regards,
Markus
Powered by blists - more mailing lists