[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CALAqxLWAWc6NZDnixWhmHg6BtGHXTy6pZ6GXM0F=SkoYH8DiQw@mail.gmail.com>
Date: Mon, 16 Dec 2019 13:13:50 -0800
From: John Stultz <john.stultz@...aro.org>
To: zhong jiang <zhongjiang@...wei.com>
Cc: "Andrew F. Davis" <afd@...com>,
Sumit Semwal <sumit.semwal@...aro.org>,
Benjamin Gaignard <benjamin.gaignard@...aro.org>,
Laura Abbott <labbott@...hat.com>,
Brian Starkey <Brian.Starkey@....com>,
lkml <linux-kernel@...r.kernel.org>, linux-media@...r.kernel.org
Subject: Re: [PATCH v2] dma-heap: Make the symbol 'dma_heap_ioctl_cmds' static
On Mon, Dec 16, 2019 at 5:43 AM zhong jiang <zhongjiang@...wei.com> wrote:
>
> Fix the following sparse warning.
>
> drivers/dma-buf/dma-heap.c:109:14: warning: symbol 'dma_heap_ioctl_cmds' was not declared. Should it be static?
>
> Signed-off-by: zhong jiang <zhongjiang@...wei.com>
> ---
> drivers/dma-buf/dma-heap.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/dma-buf/dma-heap.c b/drivers/dma-buf/dma-heap.c
> index 4f04d10..da2090e 100644
> --- a/drivers/dma-buf/dma-heap.c
> +++ b/drivers/dma-buf/dma-heap.c
> @@ -106,7 +106,7 @@ static long dma_heap_ioctl_allocate(struct file *file, void *data)
> return 0;
> }
>
> -unsigned int dma_heap_ioctl_cmds[] = {
> +static unsigned int dma_heap_ioctl_cmds[] = {
> DMA_HEAP_IOC_ALLOC,
> };
Acked-by: John Stultz <john.stultz@...aro.org>
This patch will collide with Andrew's _IOCTL_ naming change, but its a
fairly simple thing to resolve.
Sumit: If you're comfortable resolving the collision, please queue
with the rest of the recent changes for drm-misc-next.
Otherwise, I'm happy to submit the resolution I tested with here
afterwards. Let me know.
thanks
-john
Powered by blists - more mailing lists