lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 17 Feb 2020 14:18:09 +0100
From:   Paul Menzel <pmenzel@...gen.mpg.de>
To:     Ariel Elior <aelior@...vell.com>,
        Sudarsana Kalluru <skalluru@...vell.com>,
        GR-everest-linux-l2@...vell.com
Cc:     netdev@...r.kernel.org, LKML <linux-kernel@...r.kernel.org>,
        it+linux-netdev@...gen.mpg.de
Subject: bnx2x: Latest firmware requirement breaks no regression policy

Dear Linux folks,


Updating a server from 4.19.x to 5.4.x, the network device

    Ethernet controller [0200]: Broadcom Inc. and subsidiaries NetXtreme II BCM57711 10-Gigabit PCIe [14e4:164f]

failed to initialize due to missing firmware.

    bnx2x 0000:41:00.0: Direct firmware load for bnx2x/bnx2x-e1h-7.13.11.0.fw failed with error -2
    bnx2x: [bnx2x_init_firmware:13557(net02)]Can't load firmware file bnx2x/bnx2x-e1h-7.13.11.0.fw
    bnx2x: [bnx2x_func_hw_init:6002(net02)]Error loading firmware
    bnx2x: [bnx2x_nic_load:2730(net02)]HW init failed, aborting

That is undesired, because without network access one has to have
direct system access to find out what is wrong.

Could you please change the policy to only print a big warning,
if the latest firmware is not available, and an update suggestion?


Kind regards,

Paul


Download attachment "smime.p7s" of type "application/pkcs7-signature" (5174 bytes)

Powered by blists - more mailing lists