[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <4b147484-42f2-1e21-9e19-36cc696cef5e@samsung.com>
Date: Tue, 18 Feb 2020 20:13:12 +0900
From: Chanwoo Choi <cw00.choi@...sung.com>
To: "H. Nikolaus Schaller" <hns@...delico.com>,
MyungJoo Ham <myungjoo.ham@...sung.com>
Cc: linux-kernel@...r.kernel.org, letux-kernel@...nphoenux.org,
kernel@...a-handheld.com, linux-omap@...r.kernel.org
Subject: Re: [PATCH v3] extcon: palmas: hide error messages if gpio returns
-EPROBE_DEFER
On 2/17/20 10:58 PM, H. Nikolaus Schaller wrote:
>
>> Am 17.02.2020 um 14:38 schrieb H. Nikolaus Schaller <hns@...delico.com>:
>>
>> If the gpios are probed after this driver (e.g. if they
>> come from an i2c expander) there is no need to print an
>> error message.
>>
>> Signed-off-by: H. Nikolaus Schaller <hns@...delico.com>
>> ---
>> drivers/extcon/extcon-palmas.c | 8 ++++++--
>> 1 file changed, 6 insertions(+), 2 deletions(-)
>>
>> diff --git a/drivers/extcon/extcon-palmas.c b/drivers/extcon/extcon-palmas.c
>> index edc5016f46f1..cea58d0cb457 100644
>> --- a/drivers/extcon/extcon-palmas.c
>> +++ b/drivers/extcon/extcon-palmas.c
>> @@ -205,14 +205,18 @@ static int palmas_usb_probe(struct platform_device *pdev)
>>
>> palmas_usb->id_gpiod = devm_gpiod_get_optional(&pdev->dev, "id",
>> GPIOD_IN);
>> - if (IS_ERR(palmas_usb->id_gpiod)) {
>> + if (PTR_ERR(palmas_usb->id_gpiod) == -EPROBE_DEFER) {
>> + return -EPROBE_DEFER;
>> + } else if (IS_ERR(palmas_usb->id_gpiod)) {
>
> Hm.
>
> While looking again at that: why do we need the "{" and "} else "?
>
> It should be sufficient to have
>
>> palmas_usb->id_gpiod = devm_gpiod_get_optional(&pdev->dev, "id",
>> GPIOD_IN);
>> + if (PTR_ERR(palmas_usb->id_gpiod) == -EPROBE_DEFER)
>> + return -EPROBE_DEFER;
>> if (IS_ERR(palmas_usb->id_gpiod)) {
>
> What do you think is better coding style here?
I think that my suggestion is better because 'if' and 'else if'
check the error state of same 'palmas_usb->id_gpiod' variable.
If 'if' and 'else if' checks the different variable,
your suggestion is better.
--
Best Regards,
Chanwoo Choi
Samsung Electronics
Powered by blists - more mailing lists