[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <a52ef8d3-b27b-d48d-b0ab-c9b41209a6ca@linux.ibm.com>
Date: Wed, 18 Mar 2020 15:13:01 +0530
From: Ravi Bangoria <ravi.bangoria@...ux.ibm.com>
To: Christophe Leroy <christophe.leroy@....fr>
Cc: mpe@...erman.id.au, mikey@...ling.org, apopple@...ux.ibm.com,
paulus@...ba.org, npiggin@...il.com,
naveen.n.rao@...ux.vnet.ibm.com, peterz@...radead.org,
jolsa@...nel.org, oleg@...hat.com, fweisbec@...il.com,
mingo@...nel.org, linuxppc-dev@...ts.ozlabs.org,
linux-kernel@...r.kernel.org,
Ravi Bangoria <ravi.bangoria@...ux.ibm.com>
Subject: Re: [PATCH 10/15] powerpc/watchpoint: Use loop for
thread_struct->ptrace_bps
>> @@ -1628,6 +1628,9 @@ int copy_thread_tls(unsigned long clone_flags, unsigned long usp,
>> void (*f)(void);
>> unsigned long sp = (unsigned long)task_stack_page(p) + THREAD_SIZE;
>> struct thread_info *ti = task_thread_info(p);
>> +#ifdef CONFIG_HAVE_HW_BREAKPOINT
>> + int i;
>> +#endif
>
> Could we avoid all those #ifdefs ?
>
> I think if we make p->thread.ptrace_bps[] exist all the time, with a size of 0 when CONFIG_HAVE_HW_BREAKPOINT is not set, then we can drop a lot of #ifdefs.
Hmm.. what you are saying seems possible. But IMO it should be done as
independent series. Will work on it.
>
>> klp_init_thread_info(p);
>> @@ -1687,7 +1690,8 @@ int copy_thread_tls(unsigned long clone_flags, unsigned long usp,
>> p->thread.ksp_limit = (unsigned long)end_of_stack(p);
>> #endif
>> #ifdef CONFIG_HAVE_HW_BREAKPOINT
>> - p->thread.ptrace_bps[0] = NULL;
>> + for (i = 0; i < nr_wp_slots(); i++)
>> + p->thread.ptrace_bps[i] = NULL;
>> #endif
>> p->thread.fp_save_area = NULL;
>> diff --git a/arch/powerpc/kernel/ptrace.c b/arch/powerpc/kernel/ptrace.c
>> index f6d7955fc61e..e2651f86d56f 100644
>> --- a/arch/powerpc/kernel/ptrace.c
>> +++ b/arch/powerpc/kernel/ptrace.c
>
> You'll have to rebase all this on the series https://patchwork.ozlabs.org/project/linuxppc-dev/list/?series=161356 which is about to go into powerpc-next
Sure. Thanks for heads up.
>
>> @@ -2829,6 +2829,19 @@ static int set_dac_range(struct task_struct *child,
>> }
>> #endif /* CONFIG_PPC_ADV_DEBUG_DAC_RANGE */
>> +#ifdef CONFIG_HAVE_HW_BREAKPOINT
>> +static int empty_ptrace_bp(struct thread_struct *thread)
>> +{
>> + int i;
>> +
>> + for (i = 0; i < nr_wp_slots(); i++) {
>> + if (!thread->ptrace_bps[i])
>> + return i;
>> + }
>> + return -1;
>> +}
>> +#endif
>
> What does this function do exactly ? I seems to do more than what its name suggests.
It finds an empty breakpoint in ptrace_bps[]. But yeah, function name is
misleading. I'll rename it to find_empty_ptrace_bp().
...
>> @@ -2979,10 +2993,10 @@ static long ppc_del_hwdebug(struct task_struct *child, long data)
>> return -EINVAL;
>> #ifdef CONFIG_HAVE_HW_BREAKPOINT
>> - bp = thread->ptrace_bps[0];
>> + bp = thread->ptrace_bps[data - 1];
>
> Is data checked somewhere to ensure it is not out of boundaries ? Or are we sure it is always within ?
Yes. it's checked. See patch #9:
@@ -2955,7 +2975,7 @@ static long ppc_del_hwdebug(struct task_struct *child, long data)
}
return rc;
#else
- if (data != 1)
+ if (data < 1 || data > nr_wp_slots())
return -EINVAL;
#ifdef CONFIG_HAVE_HW_BREAKPOINT
Thanks,
Ravi
Powered by blists - more mailing lists