lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Sun, 12 Apr 2020 20:08:15 +0200
From:   Daniel Lezcano <daniel.lezcano@...aro.org>
To:     Rob Herring <robh@...nel.org>
Cc:     rafael@...nel.org, Zhang Rui <rui.zhang@...el.com>,
        Amit Kucheria <amit.kucheria@...durent.com>,
        Mark Rutland <mark.rutland@....com>,
        "open list:THERMAL" <linux-pm@...r.kernel.org>,
        "open list:OPEN FIRMWARE AND FLATTENED DEVICE TREE BINDINGS" 
        <devicetree@...r.kernel.org>,
        open list <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH 2/4] dt-bindings: thermal: Add the idle cooling device


Hi Rob,

thanks for the review.

On 10/04/2020 18:59, Rob Herring wrote:
> On Mon, Mar 30, 2020 at 12:03:18AM +0200, Daniel Lezcano wrote:

[ ... ]

>> +   '#cooling-cells':
>> +      const: 2
>> +      description: |
>> +         Must be 2, in order to specify minimum and maximum cooling state used in
>> +         the cooling-maps reference. The first cell is the minimum cooling state
>> +         and the second cell is the maximum cooling state requested.
>> +
>> +   duration:
>> +      $ref: /schemas/types.yaml#/definitions/uint32
>> +      description: |
>> +         The idle duration in microsecond the device begins to cool down.
>> +
>> +   latency:
>> +      $ref: /schemas/types.yaml#/definitions/uint32
>> +      description: |
>> +         The exit latency constraint in microsecond for the injected
>> +         idle state for the device.
> 
> Both of these should have unit suffix. And then they don't need a type 
> def.

Do you mean I should remove the $ref:
/schemas/types.yaml#/definitions/uint32 and change the name to
duration_us and latency_us ?

[ ... ]


-- 
<http://www.linaro.org/> Linaro.org │ Open source software for ARM SoCs

Follow Linaro:  <http://www.facebook.com/pages/Linaro> Facebook |
<http://twitter.com/#!/linaroorg> Twitter |
<http://www.linaro.org/linaro-blog/> Blog

Powered by blists - more mailing lists