lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 15 Apr 2020 11:01:53 +0200
From:   Jan Kara <jack@...e.cz>
To:     ira.weiny@...el.com
Cc:     linux-kernel@...r.kernel.org,
        "Darrick J. Wong" <darrick.wong@...cle.com>,
        Jan Kara <jack@...e.cz>,
        Dan Williams <dan.j.williams@...el.com>,
        Dave Chinner <david@...morbit.com>,
        Christoph Hellwig <hch@....de>,
        "Theodore Y. Ts'o" <tytso@....edu>, Jeff Moyer <jmoyer@...hat.com>,
        linux-ext4@...r.kernel.org, linux-xfs@...r.kernel.org,
        linux-fsdevel@...r.kernel.org
Subject: Re: [PATCH V8 09/11] fs: Introduce DCACHE_DONTCACHE

On Tue 14-04-20 23:45:21, ira.weiny@...el.com wrote:
> From: Ira Weiny <ira.weiny@...el.com>
> 
> DCACHE_DONTCACHE indicates a dentry should not be cached on final
> dput().
> 
> Also add a helper function which will flag I_DONTCACHE as well ad
> DCACHE_DONTCACHE on all dentries point to a specified inode.

I think this sentence needs more work :). Like: Also add a helper function
which will mark the inode with I_DONTCACHE flag and also mark all dentries
pointing to a specified inode as DCACHE_DONTCACHE.

> 
> Signed-off-by: Ira Weiny <ira.weiny@...el.com>
> 
> ---
> Changes from V7:
> 	new patch
> ---
>  fs/dcache.c            |  4 ++++
>  fs/inode.c             | 15 +++++++++++++++
>  include/linux/dcache.h |  2 ++
>  include/linux/fs.h     |  1 +
>  4 files changed, 22 insertions(+)

...

> diff --git a/fs/inode.c b/fs/inode.c
> index 93d9252a00ab..b8b1917a324e 100644
> --- a/fs/inode.c
> +++ b/fs/inode.c
> @@ -1526,6 +1526,21 @@ int generic_delete_inode(struct inode *inode)
>  }
>  EXPORT_SYMBOL(generic_delete_inode);
>  
> +void flag_inode_dontcache(struct inode *inode)

mark_inode_dontcache?

> +{
> +	struct dentry *dent;

This is really nitpicking but dentry variables are usually called 'de' or
'dentry' :)

> +
> +	rcu_read_lock();

I don't think this list is safe to traverse under RCU. E.g.
dentry_unlink_inode() does hlist_del_init(&dentry->d_u.d_alias). Usually,
we traverse this list under inode->i_lock protection AFAICS.

								Honza

> +	hlist_for_each_entry(dent, &inode->i_dentry, d_u.d_alias) {
> +		spin_lock(&dent->d_lock);
> +		dent->d_flags |= DCACHE_DONTCACHE;
> +		spin_unlock(&dent->d_lock);
> +	}
> +	rcu_read_unlock();
> +	inode->i_state |= I_DONTCACHE;
> +}
> +EXPORT_SYMBOL(flag_inode_dontcache);
> +
>  /*
>   * Called when we're dropping the last reference
>   * to an inode.
-- 
Jan Kara <jack@...e.com>
SUSE Labs, CR

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ