[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <3dedf704-896c-b1c1-2609-066522f89274@web.de>
Date: Sat, 18 Apr 2020 20:18:06 +0200
From: Markus Elfring <Markus.Elfring@....de>
To: Bernard Zhao <bernard@...o.com>,
Alex Deucher <alexander.deucher@....com>,
Christian König <christian.koenig@....com>,
amd-gfx@...ts.freedesktop.org, dri-devel@...ts.freedesktop.org
Cc: Felix Kühling <Felix.Kuehling@....com>,
linux-kernel@...r.kernel.org, opensource.kernel@...o.com,
Chunming Zhou <David1.Zhou@....com>,
Daniel Vetter <daniel@...ll.ch>,
David Airlie <airlied@...ux.ie>
Subject: Re: [PATCH] drm/amdgpu: Remove an unnecessary condition check in
reserve_bo_and_cond_vms()
> There is no need to if check again,
Thanks for this information.
* Should the function name be mentioned in this change description?
* Would you like to adjust the patch subject?
> maybe we could merge into the above else branch.
I suggest to reconsider this wording.
…
> +++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd_gpuvm.c
> @@ -735,10 +735,8 @@ static int reserve_bo_and_cond_vms(struct kgd_mem *mem,
…
I propose to take further coding style aspects into account.
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/Documentation/process/coding-style.rst?id=90280eaa88ac1a9140dc759941123530d5545bb6#n191
Possible refactoring:
if (ret) {
pr_err(…);
…
} else {
ctx->reserved = true;
}
How do you think about to add the tag “Fixes”?
Regards,
Markus
Powered by blists - more mailing lists