[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20200420233558.11879-1-hyunki00.koo@samsung.com>
Date: Tue, 21 Apr 2020 08:35:58 +0900
From: Hyunki Koo <hyunki00.koo@...sung.com>
To: gregkh@...uxfoundation.org, robh+dt@...nel.org,
linux-serial@...r.kernel.org, devicetree@...r.kernel.org,
linux-kernel@...r.kernel.org
Cc: hyunki00.koo@...sung.com
Subject: [PATCH v8 0/3] 32-bit access for TX/RX hold registers for
samsung_tty driver
Change in v8:
- spit into 3 patch
[1/3] create the new functions with no functional change to the code as-is.
Replace rd_regb/wr_regb with rd_reg/wr_reg for general usage.
[2/3] add the new binding reg-io-width in device tree
[3/3] add the new funtinality of rd_reg / wr_reg and wr_reg_barrier
to support 32-bit access for the TX/RX hold registers UTXH and URXH.
Change in v7:
- [1/2] correct build error on running 'make dt_binding_check'
Documentation/devicetree/bindings/serial/samsung_uart.yaml: mapping values are not allowed in this context
in "<unicode string>", line 36, column 13
Documentation/devicetree/bindings/Makefile:12: recipe for target 'Documentation/devicetree/bindings/serial/samsung_uart.example.dts' failed
make[1]: *** [Documentation/devicetree/bindings/serial/samsung_uart.example.dts] Error 1
make[1]: *** Waiting for unfinished jobs....
Makefile:1262: recipe for target 'dt_binding_check' failed
make: *** [dt_binding_check] Error 2
- [2/2] add commit message of reviewed by and tested by in commit message
Reviewed-by: Krzysztof Kozlowski <krzk@...nel.org>
Tested on Odroid HC1 (Exynos5422):
Tested-by: Krzysztof Kozlowski <krzk@...nel.org>
Change in v6:
- [2/2] clean description of reg-io-width
allOf is not needed. Just enum [1, 2] is enough.
Changes in v5:
- spit into 2 patch, newly added patch for dt-binding
[1/2] newly added dt-binding and go as first patch in this series.
[2/2] go as second patch in this series.
Changes in v4:
- correct variable types and change misleading function name
Changes in v3:
- line 2031: remove redundant init value for ourport->port.iotype
Changes in v2:
- line 954 : change rd_regl to rd_reg in for backward compatibility.
- line 2031: Add init value for ourport->port.iotype to UPIO_MEM
Hyunki Koo (3):
serial: samsung: Replace rd_regb/wr_regb with rd_reg/wr_reg
dt-bindings: serial: Add reg-io-width compatible
tty: samsung_tty: 32-bit access for TX/RX hold registers
.../devicetree/bindings/serial/samsung_uart.yaml | 8 +++
drivers/tty/serial/samsung_tty.c | 76 ++++++++++++++++++----
2 files changed, 72 insertions(+), 12 deletions(-)
--
2.15.0.rc1
Powered by blists - more mailing lists