[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <6e092ac1-7e7d-3f12-8c81-b88369f1f621@acm.org>
Date: Wed, 22 Apr 2020 16:11:41 -0700
From: Bart Van Assche <bvanassche@....org>
To: huobean@...il.com, alim.akhtar@...sung.com, avri.altman@....com,
asutoshd@...eaurora.org, jejb@...ux.ibm.com,
martin.petersen@...cle.com, stanley.chu@...iatek.com,
beanhuo@...ron.com, tomas.winkler@...el.com, cang@...eaurora.org
Cc: linux-scsi@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH v2 1/5] scsi; ufs: add device descriptor for Host
Performance Booster
On 4/16/20 1:31 PM, huobean@...il.com wrote:
> + if (desc_buf[DEVICE_DESC_PARAM_UFS_FEAT] & 0x80) {
Please introduce a symbolic name instead of using the number 0x80 directly.
> + hba->dev_info.hpb_control_mode =
> + desc_buf[DEVICE_DESC_PARAM_HPB_CTRL_MODE];
> + hba->dev_info.hpb_ver =
> + (u16) (desc_buf[DEVICE_DESC_PARAM_HPB_VER] << 8) |
> + desc_buf[DEVICE_DESC_PARAM_HPB_VER + 1];
Please use get_unaligned_be16() instead of open-coding it.
Thanks,
Bart.
Powered by blists - more mailing lists