lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 5 May 2020 05:10:43 -0700
From:   Matthew Wilcox <>
To:     Zhen Lei <>
Cc:     Minchan Kim <>, Nitin Gupta <>,
        Sergey Senozhatsky <>,
        Jens Axboe <>,
        linux-block <>,
        Andrew Morton <>,
        linux-mm <>, Alasdair Kergon <>,
        Mike Snitzer <>,
        dm-devel <>, Song Liu <>,
        linux-raid <>,
        linux-kernel <>
Subject: Re: [PATCH 1/4] block: Move SECTORS_PER_PAGE and
 SECTORS_PER_PAGE_SHIFT definitions into <linux/blkdev.h>

On Tue, May 05, 2020 at 07:55:40PM +0800, Zhen Lei wrote:
> +#endif
>  #endif

I find SECTORS_PER_PAGE_SHIFT quite hard to read.  I had a quick skim
of your other patches, and it seems to me that we could replace
'<< SECTORS_PER_PAGE_SHIFT' with '* SECTORS_PER_PAGE' and it would be
more readable in every case.

Powered by blists - more mailing lists