lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Sat, 09 May 2020 15:12:22 -0500
From: (Eric W. Biederman)
To:     Linus Torvalds <>
Cc:     Linux Kernel Mailing List <>,
        Oleg Nesterov <>, Jann Horn <>,
        Kees Cook <>,
        Greg Ungerer <>,
        Rob Landley <>,
        Bernd Edlinger <>,
        linux-fsdevel <>,
        Al Viro <>,
        Alexey Dobriyan <>,
        Andrew Morton <>,
        Casey Schaufler <>,
        LSM List <>,
        James Morris <>,
        "Serge E. Hallyn" <>,
        Andy Lutomirski <>
Subject: Re: [PATCH 2/5] exec: Directly call security_bprm_set_creds from __do_execve_file

Linus Torvalds <> writes:

> On Sat, May 9, 2020 at 12:44 PM Eric W. Biederman <> wrote:
>> Now that security_bprm_set_creds is no longer responsible for calling
>> cap_bprm_set_creds, security_bprm_set_creds only does something for
>> the primary file that is being executed (not any interpreters it may
>> have).  Therefore call security_bprm_set_creds from __do_execve_file,
>> instead of from prepare_binprm so that it is only called once, and
>> remove the now unnecessary called_set_creds field of struct binprm.
> Ahh, good, this patch removes the 'called_set_creds' logic from the
> security subsystems.
> So it does half of what I asked for: please also just rename that
> "security_bprm_set_creds()" to be "security_primary_bprm_set_creds()"
> so that the change of semantics also shows up that way.
> And so that there is no confusion about the fact that
> "cap_bprm_set_creds()" has absolutely nothing to do with
> "security_bprm_set_creds()" any more.

I agree something needs to be renamed, to remove confusion.

I am off for a nap now, and tomorrow is Mother's day so I probably won't
be back to this seriously until Monday.  But please disect these patches
and I will address any problems.


Powered by blists - more mailing lists