lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 11 Jun 2020 16:36:29 +0800
From:   "Ramuthevar, Vadivel MuruganX" 
        <vadivel.muruganx.ramuthevar@...ux.intel.com>
To:     Andy Shevchenko <andriy.shevchenko@...el.com>
Cc:     linux-kernel@...r.kernel.org, balbi@...nel.org,
        p.zabel@...gutronix.de, gregkh@...uxfoundation.org,
        robh@...nel.org, devicetree@...r.kernel.org,
        linux-usb@...r.kernel.org, cheol.yong.kim@...el.com,
        qi-ming.wu@...el.com, yin1.li@...el.com
Subject: Re: [PATCH v2 2/2] usb: phy: Add USB3 PHY support for Intel LGM SoC

Hi Andy,

Thank you so much for the review comments...

On 11/6/2020 4:12 pm, Andy Shevchenko wrote:
> On Thu, Jun 11, 2020 at 10:12:46AM +0800, Ramuthevar,Vadivel MuruganX wrote:
>> From: Ramuthevar Vadivel Murugan <vadivel.muruganx.ramuthevar@...ux.intel.com>
>>
>> Add support for USB PHY on Intel LGM SoC.
> 
> ...
> 
>> +static int get_flipped(struct tca_apb *ta, bool *flipped)
>> +{
>> +	union extcon_property_value property;
>> +	int ret;
>> +
>> +	ret = extcon_get_property(ta->phy.edev, EXTCON_USB_HOST,
>> +				  EXTCON_PROP_USB_TYPEC_POLARITY, &property);
>> +	if (ret) {
>> +		dev_err(ta->phy.dev, "no polarity property from extcon\n");
> 
>> +		return false;
> 
> return ret;
Noted.
> 
>> +	}
>> +
>> +	*flipped = property.intval;
>> +
> 
>> +	return *flipped;
> 
> return 0;
Noted.
> 
>> +}
> 
> ...I suppose it should be as above.
> 
> ...
> 
>> +	ret = readl_poll_timeout(ctrl1, val, val & SRAM_INIT_DONE,
>> +				 10, 10 * 1000);
exceeds more than 80 characters, so checkpatch throws warnings, to avoid 
that move to next line.
> 
> On one line easier to read.
> 
>> +	if (ret) {
>> +		dev_err(ta->phy.dev, "SRAM init failed, 0x%x\n", val);
>> +		return ret;
>> +	}
> 
> ...
> 
>> +static int phy_set_vbus(struct usb_phy *phy, int on)
>> +{
>> +	struct tca_apb *ta = container_of(phy, struct tca_apb, phy);
> 
>> +	int ret = 0;
> 
> Assignment is redundant.
so you mean , should be declared as
int ret;
right?

> 
>> +
>> +	if (on) {
>> +		ret = regulator_enable(ta->vbus);
>> +		if (ret)
>> +			dev_err(ta->phy.dev, "regulator not enabled\n");
>> +	} else {
>> +		ret = regulator_disable(ta->vbus);
>> +		if (ret)
>> +			dev_err(ta->phy.dev, "regulator not disabled\n");
>> +	}
>> +
>> +	return ret;
>> +}
> 
> ...
> 
>> +	ret = get_flipped(ta, &flipped);
>> +	if (!ret)
>> +		dev_err(ta->phy.dev, "no polarity property from extcon\n");
> 
> This should be fixed accordingly.
Noted.
> 
> ...
> 
>> +		dev_info(ta->phy.dev, "connected%s\n",
>> +			 flipped ? " flipped" : "");
> 
> One line.
exceeds more than 80 characters, so checkpatch throw warnings, to avoid 
that moved to next line.

Regards
Vadivel
> 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ