lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 17 Jun 2020 22:42:47 -0700
From:   Joe Perches <joe@...ches.com>
To:     Coly Li <colyli@...e.de>,
        "Gustavo A. R. Silva" <gustavoars@...nel.org>
Cc:     Kent Overstreet <kent.overstreet@...il.com>,
        linux-bcache@...r.kernel.org, linux-kernel@...r.kernel.org,
        "Gustavo A. R. Silva" <gustavo@...eddedor.com>
Subject: Re: [PATCH][next] bcache: Use struct_size() in kzalloc()

On Thu, 2020-06-18 at 13:38 +0800, Coly Li wrote:
> On 2020/6/18 06:27, Gustavo A. R. Silva wrote:
> > Make use of the struct_size() helper instead of an open-coded version
> > in order to avoid any potential type mistakes.
[]
> > diff --git a/drivers/md/bcache/writeback.c b/drivers/md/bcache/writeback.c
[]
> > -			io = kzalloc(sizeof(struct dirty_io) +
> > -				     sizeof(struct bio_vec) *
> > -				     DIV_ROUND_UP(KEY_SIZE(&w->key),
> > -						  PAGE_SECTORS),
> > +			io = kzalloc(struct_size(io, bio.bi_inline_vecs,
>                                                      ^^^^^^^^^^^^^^^^^^
>                                                      I like this :-)
> 
> > +						DIV_ROUND_UP(KEY_SIZE(&w->key), PAGE_SECTORS)),
> 
> The above line seems too long for 80 characters limitation. Does
> checkpatch.pl complain for this ?

No.  checkpatch has changed:

>From bdc48fa11e46f867ea4d75fa59ee87a7f48be144 Mon Sep 17 00:00:00 2001
From: Joe Perches <joe@...ches.com>
Date: Fri, 29 May 2020 16:12:21 -0700
Subject: [PATCH] checkpatch/coding-style: deprecate 80-column warning

Yes, staying withing 80 columns is certainly still _preferred_.  But
it's not the hard limit that the checkpatch warnings imply, and other
concerns can most certainly dominate.

Increase the default limit to 100 characters.  Not because 100
characters is some hard limit either, but that's certainly a "what are
you doing" kind of value and less likely to be about the occasional
slightly longer lines.

Miscellanea:

 - to avoid unnecessary whitespace changes in files, checkpatch will no
   longer emit a warning about line length when scanning files unless
   --strict is also used

 - Add a bit to coding-style about alignment to open parenthesis

Signed-off-by: Joe Perches <joe@...ches.com>
Signed-off-by: Linus Torvalds <torvalds@...ux-foundation.org>
> 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ