lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1c6adee3-bbad-dc88-3dd2-af823f279271@suse.de>
Date:   Thu, 18 Jun 2020 13:38:08 +0800
From:   Coly Li <colyli@...e.de>
To:     "Gustavo A. R. Silva" <gustavoars@...nel.org>
Cc:     Kent Overstreet <kent.overstreet@...il.com>,
        linux-bcache@...r.kernel.org, linux-kernel@...r.kernel.org,
        "Gustavo A. R. Silva" <gustavo@...eddedor.com>
Subject: Re: [PATCH][next] bcache: Use struct_size() in kzalloc()

On 2020/6/18 06:27, Gustavo A. R. Silva wrote:
> Make use of the struct_size() helper instead of an open-coded version
> in order to avoid any potential type mistakes.
> 
> This code was detected with the help of Coccinelle and, audited and
> fixed manually.
> 
> Signed-off-by: Gustavo A. R. Silva <gustavoars@...nel.org> ---
>  drivers/md/bcache/writeback.c | 6 ++----
>  1 file changed, 2 insertions(+), 4 deletions(-)
> 
> diff --git a/drivers/md/bcache/writeback.c b/drivers/md/bcache/writeback.c
> index 1cf1e5016cb9..c0db3c860179 100644
> --- a/drivers/md/bcache/writeback.c
> +++ b/drivers/md/bcache/writeback.c
> @@ -459,10 +459,8 @@ static void read_dirty(struct cached_dev *dc)
>  		for (i = 0; i < nk; i++) {
>  			w = keys[i];
>  
> -			io = kzalloc(sizeof(struct dirty_io) +
> -				     sizeof(struct bio_vec) *
> -				     DIV_ROUND_UP(KEY_SIZE(&w->key),
> -						  PAGE_SECTORS),
> +			io = kzalloc(struct_size(io, bio.bi_inline_vecs,
                                                     ^^^^^^^^^^^^^^^^^^
                                                     I like this :-)

> +						DIV_ROUND_UP(KEY_SIZE(&w->key), PAGE_SECTORS)),

The above line seems too long for 80 characters limitation. Does
checkpatch.pl complain for this ?


Thanks.

Coly Li


>  				     GFP_KERNEL);
>  			if (!io)
>  				goto err;
> 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ