lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 24 Jun 2020 17:27:41 +0300
From:   Alexey Budankov <alexey.budankov@...ux.intel.com>
To:     Jiri Olsa <jolsa@...hat.com>
Cc:     Arnaldo Carvalho de Melo <acme@...nel.org>,
        Namhyung Kim <namhyung@...nel.org>,
        Alexander Shishkin <alexander.shishkin@...ux.intel.com>,
        Peter Zijlstra <peterz@...radead.org>,
        Ingo Molnar <mingo@...hat.com>,
        Andi Kleen <ak@...ux.intel.com>,
        linux-kernel <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH v8 04/13] perf stat: factor out body of event handling
 loop for system wide


On 23.06.2020 17:56, Jiri Olsa wrote:
> On Wed, Jun 17, 2020 at 11:37:43AM +0300, Alexey Budankov wrote:
>>
>> Introduce process_timeout() and process_interval() functions that
>> factor out body of event handling loop for attach and system wide
>> monitoring use cases.
>>
>> Signed-off-by: Alexey Budankov <alexey.budankov@...ux.intel.com>
>> ---
>>  tools/perf/builtin-stat.c | 28 ++++++++++++++++++++--------
>>  1 file changed, 20 insertions(+), 8 deletions(-)
>>
>> diff --git a/tools/perf/builtin-stat.c b/tools/perf/builtin-stat.c
>> index 9be020e0098a..31f7ccf9537b 100644
>> --- a/tools/perf/builtin-stat.c
>> +++ b/tools/perf/builtin-stat.c
>> @@ -475,6 +475,23 @@ static void process_interval(void)
>>  	print_counters(&rs, 0, NULL);
>>  }
>>  
>> +static bool print_interval(unsigned int interval, int *times)
>> +{
>> +	if (interval) {
>> +		process_interval();
>> +		if (interval_count && !(--(*times)))
>> +			return true;
>> +	}
>> +	return false;
>> +}
>> +
>> +static bool process_timeout(int timeout, unsigned int interval, int *times)
>> +{
>> +	if (timeout)
>> +		return true;
>> +	return print_interval(interval, times);
>> +}
> 
> I think it's confusing to keep this together, that
> process_timeout triggers also interval processing
> 
> I think you can keep the timeout separated from interval
> processing and rename the print_interval to process_interval
> and process_interval to __process_interval

Well, ok.

I will rename process_interval() to __process_interval() and
then print_interval() to process_interval().

Regarding timeout let's have it like this:

static bool process_timeout(int timeout)
{
	return timeout ? true : false;
}

static bool process_timing_settings(int timeout, unsigned int interval, int *times)
{
        bool res = process_timeout(timeout);
        if (!res)
		res = process_interval(interval, times);
	return res; 
}

Ok?

~Alexey

> 
> jirka
> 
>> +
>>  static void enable_counters(void)
>>  {
>>  	if (stat_config.initial_delay)
>> @@ -611,6 +628,7 @@ static int __run_perf_stat(int argc, const char **argv, int run_idx)
>>  	struct affinity affinity;
>>  	int i, cpu;
>>  	bool second_pass = false;
>> +	bool stop = false;
>>  
>>  	if (interval) {
>>  		ts.tv_sec  = interval / USEC_PER_MSEC;
>> @@ -805,17 +823,11 @@ static int __run_perf_stat(int argc, const char **argv, int run_idx)
>>  			psignal(WTERMSIG(status), argv[0]);
>>  	} else {
>>  		enable_counters();
>> -		while (!done) {
>> +		while (!done && !stop) {
>>  			nanosleep(&ts, NULL);
>>  			if (!is_target_alive(&target, evsel_list->core.threads))
>>  				break;
>> -			if (timeout)
>> -				break;
>> -			if (interval) {
>> -				process_interval();
>> -				if (interval_count && !(--times))
>> -					break;
>> -			}
>> +			stop = process_timeout(timeout, interval, &times);
>>  		}
>>  	}
>>  
>> -- 
>> 2.24.1
>>
>>
> 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ