[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <4b0f2a2d-66be-4cdd-8384-a80f6b729d74@microchip.com>
Date: Mon, 29 Jun 2020 12:50:11 +0000
From: <Tudor.Ambarus@...rochip.com>
To: <thesven73@...il.com>, <miquel.raynal@...tlin.com>,
<richard@....at>, <vigneshr@...com>
CC: <linux-mtd@...ts.infradead.org>, <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH v1] mtd: spi-nor: Add support for Winbond w25q64jv spi
flash
Hi, Sven,
On 6/14/20 2:53 AM, Sven Van Asbroeck wrote:
> EXTERNAL EMAIL: Do not click links or open attachments unless you know the content is safe
>
> This chip is (nearly) identical to the Winbond w25q64 which is
> already supported by Linux. Compared to the w25q64, the 'jv'
> does not support Quad SPI mode, and has a different JEDEC ID.
I'm reading the following datasheet:
https://www.winbond.com/resource-files/w25q64jv%20revj%2003272018%20plus.pdf
w25q64jvm (0xef7017) comes with QE bit set to a 0 state, but can be
set to 1, so Quad mode can be supported. Would you please set SPI_NOR_DUAL_READ
and SPI_NOR_QUAD_READ flags and test and see if Quad works? If all good,
please specify in the commit message with which controller you did the tests.
>
> To: Tudor Ambarus <tudor.ambarus@...rochip.com>
> To: Miquel Raynal <miquel.raynal@...tlin.com>
> To: Richard Weinberger <richard@....at>
> To: Vignesh Raghavendra <vigneshr@...com>
> Cc: linux-mtd@...ts.infradead.org
> Cc: linux-kernel@...r.kernel.org
Are these tags really necessary? Would you drop them?
> Signed-off-by: Sven Van Asbroeck <TheSven73@...il.com>
> ---
>
> Tree: next-20200613
>
> drivers/mtd/spi-nor/winbond.c | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/drivers/mtd/spi-nor/winbond.c b/drivers/mtd/spi-nor/winbond.c
> index 5062af10f138..18bdff02f57f 100644
> --- a/drivers/mtd/spi-nor/winbond.c
> +++ b/drivers/mtd/spi-nor/winbond.c
> @@ -65,6 +65,7 @@ static const struct flash_info winbond_parts[] = {
> SPI_NOR_HAS_LOCK | SPI_NOR_HAS_TB) },
> { "w25x64", INFO(0xef3017, 0, 64 * 1024, 128, SECT_4K) },
> { "w25q64", INFO(0xef4017, 0, 64 * 1024, 128, SECT_4K) },
> + { "w25q64jv", INFO(0xef7017, 0, 64 * 1024, 128, SECT_4K) },
I would name it "w25q64jvm". Check "11.ORDERING INFORMATION". Although the
datasheet refers to these flashes as "W25Q64JV-IQ/JQ" and "W25Q64JV-IM/JM",
I find that the temperature range is not a differentiator in the flash ID,
so I would drop it.
Cheers,
ta
Powered by blists - more mailing lists