lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 6 Jul 2020 17:01:12 +0800
From:   Tiezhu Yang <yangtiezhu@...ngson.cn>
To:     Jiri Slaby <jslaby@...e.cz>,
        Greg Kroah-Hartman <gregkh@...uxfoundation.org>
Cc:     linux-kernel@...r.kernel.org, Xuefeng Li <lixuefeng@...ngson.cn>
Subject: Re: [PATCH] serial: Remove duplicated macro definition of port type

On 05/11/2020 02:40 PM, Jiri Slaby wrote:
> On 07. 05. 20, 14:03, Tiezhu Yang wrote:
>> There exists the same macro definition of port type from 0 to 13
>> in include/uapi/linux/serial.h, remove these duplicated code in
>> include/uapi/linux/serial_core.h which includes the former header.
>>
>> Signed-off-by: Tiezhu Yang <yangtiezhu@...ngson.cn>
> Acked-by: Jiri Slaby <jslaby@...e.cz>

Hi,

Could you please apply this patch?

Thanks,
Tiezhu

>
>> ---
>>   include/uapi/linux/serial_core.h | 14 --------------
>>   1 file changed, 14 deletions(-)
>>
>> diff --git a/include/uapi/linux/serial_core.h b/include/uapi/linux/serial_core.h
>> index 8ec3dd7..851b982 100644
>> --- a/include/uapi/linux/serial_core.h
>> +++ b/include/uapi/linux/serial_core.h
>> @@ -26,20 +26,6 @@
>>   /*
>>    * The type definitions.  These are from Ted Ts'o's serial.h
>>    */
>> -#define PORT_UNKNOWN	0
>> -#define PORT_8250	1
>> -#define PORT_16450	2
>> -#define PORT_16550	3
>> -#define PORT_16550A	4
>> -#define PORT_CIRRUS	5
>> -#define PORT_16650	6
>> -#define PORT_16650V2	7
>> -#define PORT_16750	8
>> -#define PORT_STARTECH	9
>> -#define PORT_16C950	10
>> -#define PORT_16654	11
>> -#define PORT_16850	12
>> -#define PORT_RSA	13
>>   #define PORT_NS16550A	14
>>   #define PORT_XSCALE	15
>>   #define PORT_RM9000	16	/* PMC-Sierra RM9xxx internal UART */
>>
> thanks,

Powered by blists - more mailing lists