lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 15 Jul 2020 10:54:48 +0900
From:   "Namjae Jeon" <namjae.jeon@...sung.com>
To:     <Kohada.Tetsuhiro@...MitsubishiElectric.co.jp>
Cc:     <Mori.Takahiro@...MitsubishiElectric.co.jp>,
        <Motai.Hirotaka@...MitsubishiElectric.co.jp>,
        "'Sungjong Seo'" <sj1557.seo@...sung.com>,
        <linux-fsdevel@...r.kernel.org>, <linux-kernel@...r.kernel.org>,
        "'Tetsuhiro Kohada''" <kohada.t2@...il.com>
Subject: RE: [PATCH] exfat: retain 'VolumeFlags' properly

> Thanks for your reply.
> 
> > > Also, rename ERR_MEDIUM to MED_FAILURE.
> > I think that MEDIA_FAILURE looks better.
> 
> I think so too.
> If so, should I change VOL_DIRTY to VOLUME_DIRTY?
Yes, maybe.
> 
> > > -int exfat_set_vol_flags(struct super_block *sb, unsigned short
> > > new_flag)
> > > +int exfat_set_vol_flags(struct super_block *sb, unsigned short
> > > +new_flags)
> > >  {
> > >  	struct exfat_sb_info *sbi = EXFAT_SB(sb);
> > >  	struct boot_sector *p_boot = (struct boot_sector *)sbi->boot_bh->b_data;
> > >  	bool sync;
> > If dirty bit is set in on-disk volume flags, we can just return 0 at the beginning of this function ?
> 
> That's right.
> Neither 'set VOL_DIRTY' nor 'set VOL_CLEAN' makes a change to volume flags.
> 
> 
> > > +	if (new_flags == VOL_CLEAN)
> > > +		new_flags = (sbi->vol_flags & ~VOL_DIRTY) | sbi->vol_flags_noclear;
> > > +	else
> > > +		new_flags |= sbi->vol_flags;
> > > +
> > >  	/* flags are not changed */
> > > -	if (sbi->vol_flag == new_flag)
> > > +	if (sbi->vol_flags == new_flags)
> > >  		return 0;
> > >
> > > -	sbi->vol_flag = new_flag;
> > > +	sbi->vol_flags = new_flags;
> > >
> > >  	/* skip updating volume dirty flag,
> > >  	 * if this volume has been mounted with read-only @@ -114,9 +119,9
> > > @@ int exfat_set_vol_flags(struct super_block *sb, unsigned short new_flag)
> > >  	if (sb_rdonly(sb))
> > >  		return 0;
> > >
> > > -	p_boot->vol_flags = cpu_to_le16(new_flag);
> > > +	p_boot->vol_flags = cpu_to_le16(new_flags);
> > How about set or clear only dirty bit to on-disk volume flags instead
> > of using
> > sbi->vol_flags_noclear ?
> >        if (set)
> >                p_boot->vol_flags |= cpu_to_le16(VOL_DIRTY);
> >        else
> >                p_boot->vol_flags &= cpu_to_le16(~VOL_DIRTY);
> 
> In this way, the initial  VOL_DIRTY cannot be retained.
> The purpose of this patch is to avoid losing the initial VOL_DIRTY and MED_FAILURE.
> Furthermore, I'm also thinking of setting MED_FAILURE.
I know what you do. I mean this function does not need to be called if volume dirty
Is already set on on-disk volume flags as I said earlier.
> 
> However, the formula for 'new_flags' may be a bit complicated.
> Is it better to change to the following?
> 
> 	if (new_flags == VOL_CLEAN)
> 		new_flags = sbi->vol_flags & ~VOL_DIRTY
> 	else
> 		new_flags |= sbi->vol_flags;
> 
> 	new_flags |= sbi->vol_flags_noclear;
> 
> 
> one more point,
> Is there a better name than 'vol_flags_noclear'?
> (I can't come up with a good name anymore)
It looks complicated. It would be better to simply set/clear VOLUME DIRTY bit.

Thanks!
> 
> BR
> ---
> Kohada Tetsuhiro <Kohada.Tetsuhiro@...MitsubishiElectric.co.jp>

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ