[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <d72ea889-9820-880d-0207-6d2f0dc23bcc@linux.intel.com>
Date: Tue, 21 Jul 2020 16:32:18 -0500
From: Pierre-Louis Bossart <pierre-louis.bossart@...ux.intel.com>
To: Harsha Priya <harshapriya.n@...el.com>,
alsa-devel@...a-project.org, broonie@...nel.org
Cc: lma@...ihalf.com, yang.jie@...ux.intel.com,
liam.r.girdwood@...ux.intel.com, rad@...ihalf.com,
zwisler@...gle.com, linux-kernel@...r.kernel.org,
sathya.prakash.m.r@...el.com, brndt@...gle.com, mw@...ihalf.com,
levinale@...omium.org,
Vamshi Krishna Gopal <vamshi.krishna.gopal@...el.com>
Subject: Re: [PATCH v7] ASoC: Intel: kbl_rt5663_rt5514_max98927: Fix
kabylake_ssp_fixup function
Hi Harsha,
this looks mostly good to me, only have a couple of nit-picks below.
Thanks!
> kabylake_ssp_fixup function uses snd_soc_dpcm to identify the codecs DAIs.
> The hw parameters are changed based on the codec DAI,
> the stream is intended for. The earlier approach to get
> snd_soc_dpcm was using container_of() macro on snd_pcm_hw_params.
> The structures have been modified over time and snd_soc_dpcm does
> not have snd_pcm_hw_params as a reference but as a copy.
> This causes the current driver to crash when used.
> This patch changes the way snd_soc_dpcm is extracted.
> The snd_soc_pcm_runtime holds 2 dpcm
> instances (one for playback and one for capture).
> The 2 codecs on this SSP are dmic and speakers.
> One is for capture and one is for playback respectively.
> Based on the direction of the stream,
> the snd_soc_dpcm is extracted from the snd_soc_pcm_runtime structure.
> Tested for all use cases of the driver.
Maybe reformat a bit and add newlines, this is difficult to read.
> Signed-off-by: Harsha Priya <harshapriya.n@...el.com>
> Signed-off-by: Vamshi Krishna Gopal <vamshi.krishna.gopal@...el.com>
> Tested-by: Lukasz Majczak <lma@...ihalf.com>
> diff --git a/sound/soc/intel/boards/kbl_rt5663_rt5514_max98927.c b/sound/soc/intel/boards/kbl_rt5663_rt5514_max98927.c
> index 584e4f9cedc2..9f4b949cc39c 100644
> --- a/sound/soc/intel/boards/kbl_rt5663_rt5514_max98927.c
> +++ b/sound/soc/intel/boards/kbl_rt5663_rt5514_max98927.c
> @@ -379,22 +379,42 @@ static int kabylake_ssp_fixup(struct snd_soc_pcm_runtime *rtd,
> struct snd_interval *chan = hw_param_interval(params,
> SNDRV_PCM_HW_PARAM_CHANNELS);
> struct snd_mask *fmt = hw_param_mask(params, SNDRV_PCM_HW_PARAM_FORMAT);
> - struct snd_soc_dpcm *dpcm = container_of(
> - params, struct snd_soc_dpcm, hw_params);
> - struct snd_soc_dai_link *fe_dai_link = dpcm->fe->dai_link;
> - struct snd_soc_dai_link *be_dai_link = dpcm->be->dai_link;
> + struct snd_soc_dpcm *dpcm, *rtd_dpcm = NULL;
The idea of initializing was also to test before dereferencing this
pointer. Without the test, this is somewhat useless, tools may still
complain about dereferencing a NULL pointer?
> +
> + /*
> + * The following loop will be called only for playback stream
> + * In this platform, there is only one playback device on every SSP
> + */
> + for_each_dpcm_fe(rtd, SNDRV_PCM_STREAM_PLAYBACK, dpcm) {
> + rtd_dpcm = dpcm;
> + break;
> + }
> +
> + /*
> + * This following loop will be called only for capture stream
> + * In this platform, there is only one capture device on every SSP
> + */
> + for_each_dpcm_fe(rtd, SNDRV_PCM_STREAM_CAPTURE, dpcm) {
> + rtd_dpcm = dpcm;
> + break;
> + }
add if (!rtd_dpcm) return -EINVAL here?
> + /*
> + * The above 2 loops are mutually exclusive based on the strem direction,
typo: stream
> + * thus rtd_dpcm variable will never be overwritten
> + */
Powered by blists - more mailing lists