[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <8FA38F12-3CB4-46A9-B654-92DC384D3103@tencent.com>
Date: Thu, 6 Aug 2020 02:42:20 +0000
From: benbjiang(蒋彪) <benbjiang@...cent.com>
To: Dietmar Eggemann <dietmar.eggemann@....com>
CC: Jiang Biao <benbjiang@...il.com>,
"mingo@...hat.com" <mingo@...hat.com>,
Peter Zijlstra <peterz@...radead.org>,
"juri.lelli@...hat.com" <juri.lelli@...hat.com>,
"vincent.guittot@...aro.org" <vincent.guittot@...aro.org>,
"rostedt@...dmis.org" <rostedt@...dmis.org>,
"bsegall@...gle.com" <bsegall@...gle.com>,
"mgorman@...e.de" <mgorman@...e.de>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH RFC] sched/fair: simplfy the work when reweighting entity
> On Aug 6, 2020, at 12:21 AM, Dietmar Eggemann <dietmar.eggemann@....com> wrote:
>
> On 04/08/2020 09:12, Jiang Biao wrote:
>> If a se is on_rq when reweighting entity, all we need should be
>> updating the load of cfs_rq, other dequeue/enqueue works could be
>> redundant, such as,
>> * account_numa_dequeue/account_numa_enqueue
>> * list_del/list_add from/into cfs_tasks
>> * nr_running--/nr_running++
>
> I think this could make sense. Have you spotted a code path where this
> gives you a change?
>
> I guess only for a task on the rq, so: entity_is_task(se) && se->on_rq
Yes, you're right. No other code path I spotted except what you list below.
>
>> Just simplfy the work. Could be helpful for the hot path.
>
> IMHO hotpath is update_cfs_group() -> reweight_entity() but this is only
> called for '!entity_is_task(se)'.
>
> See
>
> 3290 if (!gcfs_rq)
> 3291 return;
>
> in update_cfs_group().
Yes, It is.
But *nr_running--/nr_running++* works are still redundant for
‘!entity_is_task(se)' hot path. :)
Besides, I guess we could simplify the logic and make it cleaner and
more readable with this patch.
If it could make sense to you, would you mind if I resend the patch
with the commit log amended?
>
> The 'entity_is_task(se)' case is
>
> set_load_weight(struct task_struct *p, ...) -> reweight_task(p, ...) ->
> reweight_entity(..., &p->se, ...)
>
> but here !se->on_rq.
Yes, indeed.
Thanks a lot for your comments.
Regards,
Jiang
>
>> Signed-off-by: Jiang Biao <benbjiang@...cent.com>
>> ---
>> kernel/sched/fair.c | 4 ++--
>> 1 file changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c
>> index 04fa8dbcfa4d..18a8fc7bd0de 100644
>> --- a/kernel/sched/fair.c
>> +++ b/kernel/sched/fair.c
>> @@ -3086,7 +3086,7 @@ static void reweight_entity(struct cfs_rq *cfs_rq, struct sched_entity *se,
>> /* commit outstanding execution time */
>> if (cfs_rq->curr == se)
>> update_curr(cfs_rq);
>> - account_entity_dequeue(cfs_rq, se);
>> + update_load_sub(&cfs_rq->load, se->load.weight);
>> }
>> dequeue_load_avg(cfs_rq, se);
>>
>> @@ -3102,7 +3102,7 @@ static void reweight_entity(struct cfs_rq *cfs_rq, struct sched_entity *se,
>>
>> enqueue_load_avg(cfs_rq, se);
>> if (se->on_rq)
>> - account_entity_enqueue(cfs_rq, se);
>> + update_load_add(&cfs_rq->load, se->load.weight);
>>
>> }
>
Powered by blists - more mailing lists