lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 1 Oct 2020 10:06:57 +0100
From:   Jonathan Cameron <Jonathan.Cameron@...wei.com>
To:     Sean V Kelley <seanvk.dev@...gontracks.org>
CC:     <bhelgaas@...gle.com>, <rafael.j.wysocki@...el.com>,
        <ashok.raj@...el.com>, <tony.luck@...el.com>,
        <sathyanarayanan.kuppuswamy@...el.com>, <qiuxu.zhuo@...el.com>,
        <linux-pci@...r.kernel.org>, <linux-kernel@...r.kernel.org>,
        Sean V Kelley <sean.v.kelley@...el.com>
Subject: Re: [PATCH v7 05/13] PCI/ERR: Use "bridge" for clarity in
 pcie_do_recovery()

On Wed, 30 Sep 2020 14:58:12 -0700
Sean V Kelley <seanvk.dev@...gontracks.org> wrote:

> From: Sean V Kelley <sean.v.kelley@...el.com>
> 
> The term "dev" is being applied to root ports, switch
> upstream ports, switch downstream ports, and the upstream
> ports on endpoints. While endpoint upstream ports don't have
> subordinate buses, a generic term such as "bridge" may be used

This sentence is a bit confusing.  The bit before the comma
seems only slightly connected. Perhaps 2 sentences?

> for something with a subordinate bus. The current conditional
> logic in pcie_do_recovery() would also benefit from some
> simplification with use of pci_upstream_bridge() in place of
> dev->bus->self. Reverse the pcie_do_recovery() conditional logic
> and replace use of "dev" with "bridge" for greater clarity.
> 
> Suggested-by: Bjorn Helgaas <bhelgaas@...gle.com>
> Signed-off-by: Sean V Kelley <sean.v.kelley@...el.com>

Acked-by: Jonathan Cameron <Jonathan.Cameron@...wei.com>

> ---
>  drivers/pci/pcie/err.c | 20 +++++++++++++-------
>  1 file changed, 13 insertions(+), 7 deletions(-)
> 
> diff --git a/drivers/pci/pcie/err.c b/drivers/pci/pcie/err.c
> index 950612342f1c..c6922c099c76 100644
> --- a/drivers/pci/pcie/err.c
> +++ b/drivers/pci/pcie/err.c
> @@ -152,16 +152,22 @@ pci_ers_result_t pcie_do_recovery(struct pci_dev *dev,
>  {
>  	pci_ers_result_t status = PCI_ERS_RESULT_CAN_RECOVER;
>  	struct pci_bus *bus;
> +	struct pci_dev *bridge;
> +	int type;
>  
>  	/*
> -	 * Error recovery runs on all subordinates of the first downstream port.
> -	 * If the downstream port detected the error, it is cleared at the end.
> +	 * Error recovery runs on all subordinates of the first downstream
> +	 * bridge. If the downstream bridge detected the error, it is
> +	 * cleared at the end.
>  	 */
> -	if (!(pci_pcie_type(dev) == PCI_EXP_TYPE_ROOT_PORT ||
> -	      pci_pcie_type(dev) == PCI_EXP_TYPE_DOWNSTREAM))
> -		dev = dev->bus->self;
> -	bus = dev->subordinate;
> -
> +	type = pci_pcie_type(dev);
> +	if (type == PCI_EXP_TYPE_ROOT_PORT ||
> +	    type == PCI_EXP_TYPE_DOWNSTREAM)
> +		bridge = dev;
> +	else
> +		bridge = pci_upstream_bridge(dev);
> +
> +	bus = bridge->subordinate;
>  	pci_dbg(dev, "broadcast error_detected message\n");
>  	if (state == pci_channel_io_frozen) {
>  		pci_walk_bus(bus, report_frozen_detected, &status);


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ