[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1604046722-15531-2-git-send-email-luojiaxing@huawei.com>
Date: Fri, 30 Oct 2020 16:31:58 +0800
From: Luo Jiaxing <luojiaxing@...wei.com>
To: <akpm@...ux-foundation.org>, <viro@...iv.linux.org.uk>,
<andriy.shevchenko@...ux.intel.com>
CC: <linux-kernel@...r.kernel.org>, <martin.petersen@...cle.com>,
<john.garry@...wei.com>, <himanshu.madhani@...ium.com>,
<felipe.balbi@...ux.intel.com>, <gregkh@...uxfoundation.org>,
<uma.shankar@...el.com>, <anshuman.gupta@...el.com>,
<animesh.manna@...el.com>, <linux-usb@...r.kernel.org>,
<linux-scsi@...r.kernel.org>, <linuxarm@...wei.com>
Subject: [PATCH v2 1/5] seq_file: Introduce DEFINE_SHOW_STORE_ATTRIBUTE() helper macro
We already own DEFINE_SHOW_ATTRIBUTE() helper macro for defining attribute
for read-only file, but we found many of drivers want a helper marco for
read-write file too.
So we try to make one to decrease code duplication.
Signed-off-by: Luo Jiaxing <luojiaxing@...wei.com>
---
include/linux/seq_file.h | 15 +++++++++++++++
1 file changed, 15 insertions(+)
diff --git a/include/linux/seq_file.h b/include/linux/seq_file.h
index 813614d..8a474c8 100644
--- a/include/linux/seq_file.h
+++ b/include/linux/seq_file.h
@@ -191,6 +191,21 @@ static const struct proc_ops __name ## _proc_ops = { \
.proc_release = single_release, \
}
+#define DEFINE_SHOW_STORE_ATTRIBUTE(__name) \
+static int __name ## _open(struct inode *inode, struct file *file) \
+{ \
+ return single_open(file, __name ## _show, inode->i_private); \
+} \
+ \
+static const struct file_operations __name ## _fops = { \
+ .owner = THIS_MODULE, \
+ .open = __name ## _open, \
+ .read = seq_read, \
+ .write = __name ## _write, \
+ .llseek = seq_lseek, \
+ .release = single_release, \
+}
+
static inline struct user_namespace *seq_user_ns(struct seq_file *seq)
{
#ifdef CONFIG_USER_NS
--
2.7.4
Powered by blists - more mailing lists