lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 3 Nov 2020 16:19:09 +0800
From:   luojiaxing <luojiaxing@...wei.com>
To:     Greg KH <gregkh@...uxfoundation.org>
CC:     <akpm@...ux-foundation.org>, <viro@...iv.linux.org.uk>,
        <andriy.shevchenko@...ux.intel.com>,
        <linux-kernel@...r.kernel.org>, <martin.petersen@...cle.com>,
        <john.garry@...wei.com>, <himanshu.madhani@...ium.com>,
        <felipe.balbi@...ux.intel.com>, <uma.shankar@...el.com>,
        <anshuman.gupta@...el.com>, <animesh.manna@...el.com>,
        <linux-usb@...r.kernel.org>, <linux-scsi@...r.kernel.org>,
        <linuxarm@...wei.com>
Subject: Re: [PATCH v2 0/5] Introduce a new helper marco
 DEFINE_SHOW_STORE_ATTRIBUTE at seq_file.c

Hi

On 2020/10/30 16:44, Greg KH wrote:
> On Fri, Oct 30, 2020 at 04:31:57PM +0800, Luo Jiaxing wrote:
>> We already own DEFINE_SHOW_ATTRIBUTE() helper macro for defining attribute
>> for read-only file, but we found many of drivers also want a helper marco for
>> read-write file too.
>>
>> So we try to add this macro to help decrease code duplication.
>>
>> Luo Jiaxing (5):
>>    seq_file: Introduce DEFINE_SHOW_STORE_ATTRIBUTE() helper macro
>>    scsi: hisi_sas: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs
>>    scsi: qla2xxx: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs
>>    usb: dwc3: debugfs: Introduce DEFINE_SHOW_STORE_ATTRIBUTE
>>    drm/i915/display: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs
> What changed from v1?


Sorry, I should add a commit for the change.


In v1, Andy pointed out that the old name of DEFINE_STORE_ATTRIBUTE was 
easily misunderstood as a write-only file rather than a read-write file.

Therefore, it is changed to DEFINE_SHOW_STORE_ATTRIBUTE according to his 
suggestion.


Thanks

Jiaxing


>
> thanks,
>
> greg k-h
>
> .
>

Powered by blists - more mailing lists