lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 24 Nov 2020 11:55:51 -0800
From:   "Paul E. McKenney" <paulmck@...nel.org>
To:     "Uladzislau Rezki (Sony)" <urezki@...il.com>
Cc:     LKML <linux-kernel@...r.kernel.org>, RCU <rcu@...r.kernel.org>,
        Andrew Morton <akpm@...ux-foundation.org>,
        Frederic Weisbecker <frederic@...nel.org>,
        Neeraj Upadhyay <neeraju@...eaurora.org>,
        Joel Fernandes <joel@...lfernandes.org>,
        Peter Zijlstra <peterz@...radead.org>,
        Michal Hocko <mhocko@...e.com>,
        Thomas Gleixner <tglx@...utronix.de>,
        "Theodore Y . Ts'o" <tytso@....edu>,
        Sebastian Andrzej Siewior <bigeasy@...utronix.de>,
        Oleksiy Avramchenko <oleksiy.avramchenko@...ymobile.com>
Subject: Re: [PATCH 2/2] rcu: eliminate the __kvfree_rcu() macro

On Fri, Nov 20, 2020 at 12:49:17PM +0100, Uladzislau Rezki (Sony) wrote:
> Make the kvfree_rcu_arg_2() to be open-coded, so readability
> and review look better from the first glance. Moreover, that
> makes it clear that both kvfree_rcu_arg_1/2() use one single
> interface.
> 
> Signed-off-by: Uladzislau Rezki (Sony) <urezki@...il.com>

I queued both with the usual editing, thank you!

							Thanx, Paul

> ---
>  include/linux/rcupdate.h | 18 ++++++------------
>  1 file changed, 6 insertions(+), 12 deletions(-)
> 
> diff --git a/include/linux/rcupdate.h b/include/linux/rcupdate.h
> index b1e75648d402..6d56dd7e6a30 100644
> --- a/include/linux/rcupdate.h
> +++ b/include/linux/rcupdate.h
> @@ -842,15 +842,6 @@ static inline notrace void rcu_read_unlock_sched_notrace(void)
>   */
>  #define __is_kvfree_rcu_offset(offset) ((offset) < 4096)
>  
> -/*
> - * Helper macro for kfree_rcu() to prevent argument-expansion eyestrain.
> - */
> -#define __kvfree_rcu(head, offset) \
> -	do { \
> -		BUILD_BUG_ON(!__is_kvfree_rcu_offset(offset)); \
> -		kvfree_call_rcu(head, (rcu_callback_t)(unsigned long)(offset)); \
> -	} while (0)
> -
>  /**
>   * kfree_rcu() - kfree an object after a grace period.
>   * @ptr: pointer to kfree(both for single argument and double one)
> @@ -868,7 +859,7 @@ static inline notrace void rcu_read_unlock_sched_notrace(void)
>   * Because the functions are not allowed in the low-order 4096 bytes of
>   * kernel virtual memory, offsets up to 4095 bytes can be accommodated.
>   * If the offset is larger than 4095 bytes, a compile-time error will
> - * be generated in __kvfree_rcu(). If this error is triggered, you can
> + * be generated in kvfree_rcu_arg_2(). If this error is triggered, you can
>   * either fall back to use of call_rcu() or rearrange the structure to
>   * position the rcu_head structure into the first 4096 bytes.
>   *
> @@ -914,8 +905,11 @@ static inline notrace void rcu_read_unlock_sched_notrace(void)
>  do {									\
>  	typeof (ptr) ___p = (ptr);					\
>  									\
> -	if (___p)							\
> -		__kvfree_rcu(&((___p)->rhf), offsetof(typeof(*(ptr)), rhf)); \
> +	if (___p) {									\
> +		BUILD_BUG_ON(!__is_kvfree_rcu_offset(offsetof(typeof(*(ptr)), rhf)));	\
> +		kvfree_call_rcu(&((___p)->rhf), (rcu_callback_t)(unsigned long)		\
> +			(offsetof(typeof(*(ptr)), rhf)));				\
> +	}										\
>  } while (0)
>  
>  #define kvfree_rcu_arg_1(ptr)					\
> -- 
> 2.20.1
> 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ