[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20210128084455.2237256-1-geert+renesas@glider.be>
Date: Thu, 28 Jan 2021 09:44:51 +0100
From: Geert Uytterhoeven <geert+renesas@...der.be>
To: Vinod Koul <vkoul@...nel.org>
Cc: Rob Herring <robh+dt@...nel.org>,
Dan Williams <dan.j.williams@...el.com>,
Laurent Pinchart <laurent.pinchart@...asonboard.com>,
Wolfram Sang <wsa+renesas@...g-engineering.com>,
Yoshihiro Shimoda <yoshihiro.shimoda.uh@...esas.com>,
dmaengine@...r.kernel.org, devicetree@...r.kernel.org,
linux-renesas-soc@...r.kernel.org, linux-kernel@...r.kernel.org,
Geert Uytterhoeven <geert+renesas@...der.be>
Subject: [PATCH v3 0/4] dmaengine: rcar-dmac: Add support for R-Car V3U
Hi Vinod,
This patch series adds support for the Direct Memory Access Controller
variant in the Renesas R-Car V3U (R8A779A0) SoC, to both DT bindings and
driver.
Changes compared to v2:
- Add Reviewed-by, Tested-by,
- Place iterator after container being iterated,
- Stop passing index to rcar_dmac_chan_probe().
Changes compared to v1:
- Add Reviewed-by,
- Put the full loop control of for_each_rcar_dmac_chan() on a single
line, to improve readability,
- Use two separate named regions instead of array,
- Drop rcar_dmac_of_data.chan_reg_block, check for
!rcar_dmac_of_data.chan_offset_base instead,
- Precalculate chan_base in rcar_dmac_probe().
This has been tested on the Renesas Falcon board, using external SPI
loopback (spi-loopback-test) on MSIOF1 and MSIOF2.
Thanks!
Geert Uytterhoeven (4):
dt-bindings: renesas,rcar-dmac: Add r8a779a0 support
dmaengine: rcar-dmac: Add for_each_rcar_dmac_chan() helper
dmaengine: rcar-dmac: Add helpers for clearing DMA channel status
dmaengine: rcar-dmac: Add support for R-Car V3U
.../bindings/dma/renesas,rcar-dmac.yaml | 76 +++++++-----
drivers/dma/sh/rcar-dmac.c | 112 ++++++++++++------
2 files changed, 126 insertions(+), 62 deletions(-)
--
2.25.1
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@...ux-m68k.org
In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds
Powered by blists - more mailing lists