[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <e7ea55b9-a5f6-0daf-843b-e25d8c70e980@nvidia.com>
Date: Tue, 9 Feb 2021 23:16:07 -0800
From: John Hubbard <jhubbard@...dia.com>
To: Minchan Kim <minchan@...nel.org>,
Greg KH <gregkh@...uxfoundation.org>
CC: Andrew Morton <akpm@...ux-foundation.org>,
linux-mm <linux-mm@...ck.org>,
LKML <linux-kernel@...r.kernel.org>, <surenb@...gle.com>,
<joaodias@...gle.com>, <willy@...radead.org>
Subject: Re: [PATCH v2] mm: cma: support sysfs
On 2/9/21 11:12 PM, Minchan Kim wrote:
...
>>> Agreed. How about this for the warning part?
>>>
>>> +
>>> +/*
>>> + * note: kobj_type should provide a release function to free dynamically
>>> + * allocated object since kobject is responsible for controlling lifespan
>>> + * of the object. However, cma_area is static object so technially, it
>>> + * doesn't need release function. It's very exceptional case so pleaes
>>> + * do not follow this model.
>>> + */
>>> static struct kobj_type cma_ktype = {
>>> .sysfs_ops = &kobj_sysfs_ops,
>>> .default_groups = cma_groups
>>> + .release = NULL, /* do not follow. See above */
>>> };
>>>
>>
>> No, please no. Just do it the correct way, what is the objection to
>> creating a few dynamic kobjects from the heap? How many of these are
>> you going to have that it will somehow be "wasteful"?
>>
>> Please do it properly.
>
> Oh, I misunderstood your word "don't provide a release function for the
> kobject" so thought you agreed on John. If you didn't, we are stuck again:
> IIUC, the objection from John was the cma_stat lifetime should be on parent
> object, which is reasonable and make code simple.
> Frankly speaking, I don't have strong opinion about either approach.
> John?
>
We should do it as Greg requests, now that it's quite clear that he's insisting
on this. Not a big deal.
I just am not especially happy about the inability to do natural, efficient
things here, such as use a statically allocated set of things with sysfs. And
I remain convinced that the above is not "improper"; it's a reasonable
step, given the limitations of the current sysfs design. I just wanted to say
that out loud, as my proposal sinks to the bottom of the trench here. haha :)
thanks,
--
John Hubbard
NVIDIA
Powered by blists - more mailing lists