[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <your-ad-here.call-01614369728-ext-5933@work.hours>
Date: Fri, 26 Feb 2021 21:02:08 +0100
From: Vasily Gorbik <gor@...ux.ibm.com>
To: Linus Torvalds <torvalds@...ux-foundation.org>
Cc: Heiko Carstens <hca@...ux.ibm.com>,
Christian Borntraeger <borntraeger@...ibm.com>,
Sven Schnelle <svens@...ux.ibm.com>,
linux-kernel@...r.kernel.org, linux-s390@...r.kernel.org
Subject: [GIT PULL] s390 patches for the 5.12 merge window #2
Hello Linus,
please pull the second round of s390 fixes and features for 5.12.
Thank you,
Vasily
The following changes since commit df24212a493afda0d4de42176bea10d45825e9a0:
Merge tag 's390-5.12-1' of git://git.kernel.org/pub/scm/linux/kernel/git/s390/linux (2021-02-21 13:40:06 -0800)
are available in the Git repository at:
git://git.kernel.org/pub/scm/linux/kernel/git/s390/linux.git tags/s390-5.12-2
for you to fetch changes up to cf6acb8bdb1d829b85a4daa2944bf9e71c93f4b9:
s390/cpumf: Add support for complete counter set extraction (2021-02-24 00:31:23 +0100)
----------------------------------------------------------------
s390 updates for the 5.12 merge window #2
- Fix physical vs virtual confusion in some basic mm macros and
routines. Caused by __pa == __va on s390 currently.
- Get rid of on-stack cpu masks.
- Add support for complete CPU counter set extraction.
- Add arch_irq_work_raise implementation.
- virtio-ccw revision and opcode fixes.
----------------------------------------------------------------
Alexander Gordeev (4):
s390/mm: make pXd_deref() macros return a pointer
s390/mm: fix invalid __pa() usage in pfn_pXd() macros
s390/mm: fix phys vs virt confusion in pgtable allocation routines
s390/mm: fix phys vs virt confusion in vmem_*() functions family
Cornelia Huck (1):
virtio/s390: implement virtio-ccw revision 2 correctly
Heiko Carstens (5):
s390/opcodes: rename selhhhr to selfhr
s390/smp: consolidate locking for smp_rescan()
s390/smp: __smp_rescan_cpus() - move cpumask away from stack
s390/smp: smp_emergency_stop() - move cpumask away from stack
s390/topology: move cpumasks away from stack
Ilya Leoshkevich (1):
s390/smp: implement arch_irq_work_raise()
Thomas Richter (1):
s390/cpumf: Add support for complete counter set extraction
arch/s390/include/asm/irq_work.h | 12 +
arch/s390/include/asm/pgalloc.h | 2 +-
arch/s390/include/asm/pgtable.h | 16 +-
arch/s390/include/uapi/asm/perf_cpum_cf_diag.h | 51 +++
arch/s390/kernel/perf_cpum_cf_diag.c | 548 +++++++++++++++++++++++--
arch/s390/kernel/smp.c | 28 +-
arch/s390/kernel/topology.c | 25 +-
arch/s390/mm/pgalloc.c | 22 +-
arch/s390/mm/vmem.c | 30 +-
arch/s390/tools/opcodes.txt | 2 +-
drivers/s390/virtio/virtio_ccw.c | 4 +-
include/linux/cpuhotplug.h | 1 +
12 files changed, 660 insertions(+), 81 deletions(-)
create mode 100644 arch/s390/include/asm/irq_work.h
create mode 100644 arch/s390/include/uapi/asm/perf_cpum_cf_diag.h
Powered by blists - more mailing lists