[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20210305165510.GA3885132@xps15>
Date: Fri, 5 Mar 2021 09:55:10 -0700
From: Mathieu Poirier <mathieu.poirier@...aro.org>
To: Arnaud POULIQUEN <arnaud.pouliquen@...s.st.com>
Cc: Bjorn Andersson <bjorn.andersson@...aro.org>,
Ohad Ben-Cohen <ohad@...ery.com>,
Andy Gross <agross@...nel.org>,
linux-remoteproc@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-stm32@...md-mailman.stormreply.com,
linux-arm-msm@...r.kernel.org
Subject: Re: [PATCH v5 08/16] rpmsg: glink: add sendto and trysendto ops
[...]
> >> }
> >>
> >> +static int qcom_glink_sendto(struct rpmsg_endpoint *ept, void *data, int len, u32 dst)
> >> +{
> >> + struct glink_channel *channel = to_glink_channel(ept);
> >> +
> >> + return __qcom_glink_send(channel, data, len, true);
> >> +}
> >> +
> >> +static int qcom_glink_trysendto(struct rpmsg_endpoint *ept, void *data, int len, u32 dst)
> >> +{
> >> + struct glink_channel *channel = to_glink_channel(ept);
> >> +
> >> + return __qcom_glink_send(channel, data, len, false);
> >> +}
> >
> > Just rename send() to sendto() and trysend() to trysendto() and ignore the
> > destination address.
>
Apologies for not being clear.
> Function prototypes have to match with rpmsg_endpoint_ops structure defined
> below. So seems to me not possible to just rename the functions.
> Please could you clarify if i missed something?
I don't think rproc_ops::send() and rproc_ops::trysend() are used anywhere else.
So replace them with rproc_ops::sendto() and rproc_ops::trysendto() where the
destination address would be ingnored.
>
> > The same goes for the next patch. I would fold patch 08
> > and 09 into 10 to help get the big picture.
>
> I'm going to squash all in one.
Perfect
>
> Thanks,
> Arnaud
>
> >
> >> +
> >> /*
> >> * Finds the device_node for the glink child interested in this channel.
> >> */
> >> @@ -1364,7 +1378,9 @@ static const struct rpmsg_device_ops glink_device_ops = {
> >> static const struct rpmsg_endpoint_ops glink_endpoint_ops = {
> >> .destroy_ept = qcom_glink_destroy_ept,
> >> .send = qcom_glink_send,
> >> + .sendto = qcom_glink_sendto,
> >> .trysend = qcom_glink_trysend,
> >> + .trysendto = qcom_glink_trysendto,
> >> };
> >>
> >> static void qcom_glink_rpdev_release(struct device *dev)
> >> --
> >> 2.17.1
> >>
Powered by blists - more mailing lists