[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <7e5eb8c54d7dd196ea071b7f9c31c2ce@protonic.nl>
Date: Tue, 23 Mar 2021 08:59:59 +0100
From: robin <robin@...tonic.nl>
To: Geert Uytterhoeven <geert@...ux-m68k.org>
Cc: Rob Herring <robh+dt@...nel.org>, Miguel Ojeda <ojeda@...nel.org>,
Paul Burton <paulburton@...nel.org>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
devicetree@...r.kernel.org, linux-mips@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH 09/17] auxdisplay: ht16k33: Use HT16K33_FB_SIZE in
ht16k33_initialize()
On 2021-03-22 15:48, Geert Uytterhoeven wrote:
> Use the existing HT16K33_FB_SIZE definition instead of open-coding the
> same calculation using an hardcoded value.
> While at it, restore reverse Christmas tree variable declaration order.
>
> Signed-off-by: Geert Uytterhoeven <geert@...ux-m68k.org>
> ---
> drivers/auxdisplay/ht16k33.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/auxdisplay/ht16k33.c
> b/drivers/auxdisplay/ht16k33.c
> index 1e69cc6d21a0dca2..6d39f12054618fa5 100644
> --- a/drivers/auxdisplay/ht16k33.c
> +++ b/drivers/auxdisplay/ht16k33.c
> @@ -168,9 +168,9 @@ static void ht16k33_fb_update(struct work_struct
> *work)
>
> static int ht16k33_initialize(struct ht16k33_priv *priv)
> {
> + uint8_t data[HT16K33_FB_SIZE];
> uint8_t byte;
> int err;
> - uint8_t data[HT16K33_MATRIX_LED_MAX_COLS * 2];
>
> /* Clear RAM (8 * 16 bits) */
> memset(data, 0, sizeof(data));
Acked-by: Robin van der Gracht <robin@...tonic.nl>
Powered by blists - more mailing lists