[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <YGHxNFXAjcg4PfnE@smile.fi.intel.com>
Date: Mon, 29 Mar 2021 18:24:36 +0300
From: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
To: Syed Nayyar Waris <syednwaris@...il.com>
Cc: bgolaszewski@...libre.com, vilhelm.gray@...il.com,
michal.simek@...inx.com, arnd@...db.de, rrichter@...vell.com,
linus.walleij@...aro.org, yamada.masahiro@...ionext.com,
akpm@...ux-foundation.org, rui.zhang@...el.com,
daniel.lezcano@...aro.org, amit.kucheria@...durent.com,
linux-arch@...r.kernel.org, linux-gpio@...r.kernel.org,
linux-kernel@...r.kernel.org, linux-arm-kernel@...ts.infradead.org,
linux-pm@...r.kernel.org
Subject: Re: [PATCH v3 3/3] gpio: xilinx: Utilize generic bitmap_get_value
and _set_value
On Sat, Mar 06, 2021 at 07:36:30PM +0530, Syed Nayyar Waris wrote:
> This patch reimplements the xgpio_set_multiple() function in
> drivers/gpio/gpio-xilinx.c to use the new generic functions:
> bitmap_get_value() and bitmap_set_value(). The code is now simpler
> to read and understand. Moreover, instead of looping for each bit
> in xgpio_set_multiple() function, now we can check each channel at
> a time and save cycles.
...
> + u32 *const state = chip->gpio_state;
Looking at this... What's the point of the const here?
Am I right that this tells: pointer is a const, while the data underneath
can be modified?
> + unsigned int *const width = chip->gpio_width;
Ditto.
Putting const:s here and there for sake of the const is not good practice.
It makes code harder to read.
--
With Best Regards,
Andy Shevchenko
Powered by blists - more mailing lists