[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20210518075254.GN1955@kadam>
Date: Tue, 18 May 2021 10:52:54 +0300
From: Dan Carpenter <dan.carpenter@...cle.com>
To: Tang Bin <tangbin@...s.chinamobile.com>
Cc: lars@...afoo.de, Michael.Hennerich@...log.com, jic23@...nel.org,
knaack.h@....de, pmeerw@...erw.net, gregkh@...uxfoundation.org,
linux-iio@...r.kernel.org, devel@...verdev.osuosl.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH] staging: iio: cdc: ad7746: Fix unnecessary check and
assignment in ad7746_probe()
On Mon, May 17, 2021 at 11:00:06PM +0800, Tang Bin wrote:
> @@ -730,11 +730,7 @@ static int ad7746_probe(struct i2c_client *client,
> if (ret < 0)
> return ret;
>
> - ret = devm_iio_device_register(indio_dev->dev.parent, indio_dev);
> - if (ret)
> - return ret;
> -
> - return 0;
> + return devm_iio_device_register(indio_dev->dev.parent, indio_dev);
> }
This sort of thing is done deliberately as a style choice... I probably
wouldn't have written it that way myself, but there really isn't a
downside to leaving it as-is.
The unused "int ret = 0;" just introduces a static checker warning about
unused assignments and disables the static checker warning for
uninitialized variables so we want to remove that.
regards,
dan carpenter
Powered by blists - more mailing lists