[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <b3f785d4dccf7f8235103f85d814be34c51987e6.camel@amazon.com>
Date: Wed, 19 May 2021 08:54:49 +0000
From: "Stamatis, Ilias" <ilstam@...zon.com>
To: "seanjc@...gle.com" <seanjc@...gle.com>
CC: "kvm@...r.kernel.org" <kvm@...r.kernel.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"jmattson@...gle.com" <jmattson@...gle.com>,
"Woodhouse, David" <dwmw@...zon.co.uk>,
"vkuznets@...hat.com" <vkuznets@...hat.com>,
"joro@...tes.org" <joro@...tes.org>,
"mtosatti@...hat.com" <mtosatti@...hat.com>,
"zamsden@...il.com" <zamsden@...il.com>,
"pbonzini@...hat.com" <pbonzini@...hat.com>,
"mlevitsk@...hat.com" <mlevitsk@...hat.com>,
"wanpengli@...cent.com" <wanpengli@...cent.com>
Subject: Re: [PATCH v2 02/10] KVM: X86: Store L1's TSC scaling ratio in 'struct
kvm_vcpu_arch'
On Tue, 2021-05-18 at 22:52 +0000, Sean Christopherson wrote:
> On Wed, May 12, 2021, Ilias Stamatis wrote:
> > Store L1's scaling ratio in that struct like we already do for L1's TSC
>
> s/that struct/kvm_vcpu_arch. Forcing the reader to look at the subject to
> understand the changelog is annoying, especially when it saves all of a handful
> of characters. E.g. I often read patches without the subject in scope.
>
> > offset. This allows for easy save/restore when we enter and then exit
> > the nested guest.
> >
> > Signed-off-by: Ilias Stamatis <ilstam@...zon.com>
> > Reviewed-by: Maxim Levitsky <mlevitsk@...hat.com>
> > ---
>
> ...
>
> > diff --git a/arch/x86/kvm/x86.c b/arch/x86/kvm/x86.c
> > index 9b6bca616929..07cf5d7ece38 100644
> > --- a/arch/x86/kvm/x86.c
> > +++ b/arch/x86/kvm/x86.c
> > @@ -2185,6 +2185,7 @@ static int set_tsc_khz(struct kvm_vcpu *vcpu, u32 user_tsc_khz, bool scale)
> >
> > /* Guest TSC same frequency as host TSC? */
> > if (!scale) {
> > + vcpu->arch.l1_tsc_scaling_ratio = kvm_default_tsc_scaling_ratio;
> > vcpu->arch.tsc_scaling_ratio = kvm_default_tsc_scaling_ratio;
>
> Looks like these are always set as a pair, maybe add a helper, e.g.
>
> static void kvm_set_l1_tsc_scaling_ratio(u64 ratio)
> {
> vcpu->arch.l1_tsc_scaling_ratio = ratio;
> vcpu->arch.tsc_scaling_ratio = ratio;
> }
>
Hmm, they are not *always* set as a pair. Plus wouldn't this name be a bit
misleading suggesting that L1's scaling ratio is updated but implicitly
changing the current ratio too?
I'm not sure a helper function would add much
value here.
> > return 0;
> > }
> > @@ -2211,7 +2212,7 @@ static int set_tsc_khz(struct kvm_vcpu *vcpu, u32 user_tsc_khz, bool scale)
> > return -1;
> > }
> >
> > - vcpu->arch.tsc_scaling_ratio = ratio;
> > + vcpu->arch.l1_tsc_scaling_ratio = vcpu->arch.tsc_scaling_ratio = ratio;
> > return 0;
> > }
> >
> > @@ -2223,6 +2224,7 @@ static int kvm_set_tsc_khz(struct kvm_vcpu *vcpu, u32 user_tsc_khz)
> > /* tsc_khz can be zero if TSC calibration fails */
> > if (user_tsc_khz == 0) {
> > /* set tsc_scaling_ratio to a safe value */
> > + vcpu->arch.l1_tsc_scaling_ratio = kvm_default_tsc_scaling_ratio;
> > vcpu->arch.tsc_scaling_ratio = kvm_default_tsc_scaling_ratio;
> > return -1;
> > }
> > @@ -2459,7 +2461,7 @@ static inline void adjust_tsc_offset_guest(struct kvm_vcpu *vcpu,
> >
> > static inline void adjust_tsc_offset_host(struct kvm_vcpu *vcpu, s64 adjustment)
> > {
> > - if (vcpu->arch.tsc_scaling_ratio != kvm_default_tsc_scaling_ratio)
> > + if (vcpu->arch.l1_tsc_scaling_ratio != kvm_default_tsc_scaling_ratio)
> > WARN_ON(adjustment < 0);
> > adjustment = kvm_scale_tsc(vcpu, (u64) adjustment);
> > adjust_tsc_offset_guest(vcpu, adjustment);
> > --
> > 2.17.1
> >
Powered by blists - more mailing lists