[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <1621928447-456653-1-git-send-email-wubo40@huawei.com>
Date: Tue, 25 May 2021 15:40:47 +0800
From: Wu Bo <wubo40@...wei.com>
To: <miklos@...redi.hu>, <linux-fsdevel@...r.kernel.org>,
<linux-kernel@...r.kernel.org>
CC: <linfeilong@...wei.com>, <wubo40@...wei.com>
Subject: [PATCH] fuse: use DIV_ROUND_UP helper macro for calculations
From: Wu Bo <wubo40@...wei.com>
Replace open coded divisor calculations with the DIV_ROUND_UP kernel
macro for better readability.
Signed-off-by: Wu Bo <wubo40@...wei.com>
---
fs/fuse/file.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/fs/fuse/file.c b/fs/fuse/file.c
index 09ef2a4..62443eb 100644
--- a/fs/fuse/file.c
+++ b/fs/fuse/file.c
@@ -1405,7 +1405,7 @@ static int fuse_get_user_pages(struct fuse_args_pages *ap, struct iov_iter *ii,
nbytes += ret;
ret += start;
- npages = (ret + PAGE_SIZE - 1) / PAGE_SIZE;
+ npages = DIV_ROUND_UP(ret, PAGE_SIZE);
ap->descs[ap->num_pages].offset = start;
fuse_page_descs_length_init(ap->descs, ap->num_pages, npages);
--
1.8.3.1
Powered by blists - more mailing lists