[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <79744e88-7f72-ce71-c379-cf749a6ba2f4@huawei.com>
Date: Tue, 1 Jun 2021 14:10:10 +0800
From: Wu Bo <wubo40@...wei.com>
To: <miklos@...redi.hu>, <linux-fsdevel@...r.kernel.org>,
<linux-kernel@...r.kernel.org>
CC: <linfeilong@...wei.com>
Subject: Re: [PATCH] fuse: use DIV_ROUND_UP helper macro for calculations
ping ...
On 2021/5/25 15:40, Wu Bo wrote:
> From: Wu Bo <wubo40@...wei.com>
>
> Replace open coded divisor calculations with the DIV_ROUND_UP kernel
> macro for better readability.
>
> Signed-off-by: Wu Bo <wubo40@...wei.com>
> ---
> fs/fuse/file.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/fs/fuse/file.c b/fs/fuse/file.c
> index 09ef2a4..62443eb 100644
> --- a/fs/fuse/file.c
> +++ b/fs/fuse/file.c
> @@ -1405,7 +1405,7 @@ static int fuse_get_user_pages(struct fuse_args_pages *ap, struct iov_iter *ii,
> nbytes += ret;
>
> ret += start;
> - npages = (ret + PAGE_SIZE - 1) / PAGE_SIZE;
> + npages = DIV_ROUND_UP(ret, PAGE_SIZE);
>
> ap->descs[ap->num_pages].offset = start;
> fuse_page_descs_length_init(ap->descs, ap->num_pages, npages);
>
Powered by blists - more mailing lists