[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <144f1781-1c06-8a00-25dc-6f32e1f348be@gmail.com>
Date: Mon, 31 May 2021 10:41:04 +0300
From: Péter Ujfalusi <peter.ujfalusi@...il.com>
To: YueHaibing <yuehaibing@...wei.com>, jarkko.nikula@...mer.com,
lgirdwood@...il.com, broonie@...nel.org, perex@...ex.cz,
tiwai@...e.com
Cc: alsa-devel@...a-project.org, linux-omap@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH -next] ASoC: ti: omap-mcbsp: use DEVICE_ATTR_RW macro
On 28/05/2021 09:30, YueHaibing wrote:
> Use DEVICE_ATTR_RW() helper instead of plain DEVICE_ATTR(),
> which makes the code a bit shorter and easier to read.
Acked-by: Peter Ujfalusi <peter.ujfalusi@...il.com>
> Signed-off-by: YueHaibing <yuehaibing@...wei.com>
> ---
> sound/soc/ti/omap-mcbsp.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/sound/soc/ti/omap-mcbsp.c b/sound/soc/ti/omap-mcbsp.c
> index db47981768c5..4479d74f0a45 100644
> --- a/sound/soc/ti/omap-mcbsp.c
> +++ b/sound/soc/ti/omap-mcbsp.c
> @@ -539,7 +539,7 @@ static ssize_t prop##_store(struct device *dev, \
> return size; \
> } \
> \
> -static DEVICE_ATTR(prop, 0644, prop##_show, prop##_store)
> +static DEVICE_ATTR_RW(prop)
>
> THRESHOLD_PROP_BUILDER(max_tx_thres);
> THRESHOLD_PROP_BUILDER(max_rx_thres);
>
--
Péter
Powered by blists - more mailing lists