[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <e860684e-959b-d126-bb1d-3214878ab995@oracle.com>
Date: Tue, 8 Jun 2021 13:16:21 +0800
From: Anand Jain <anand.jain@...cle.com>
To: Baokun Li <libaokun1@...wei.com>, linux-kernel@...r.kernel.org,
Chris Mason <clm@...com>, Josef Bacik <josef@...icpanda.com>,
David Sterba <dsterba@...e.com>
Cc: weiyongjun1@...wei.com, yuehaibing@...wei.com,
yangjihong1@...wei.com, yukuai3@...wei.com,
linux-btrfs@...r.kernel.org, kernel-janitors@...r.kernel.org,
Hulk Robot <hulkci@...wei.com>
Subject: Re: [PATCH -next] btrfs: send: use list_move_tail instead of
list_del/list_add_tail
On 8/6/21 11:12 am, Baokun Li wrote:
> Using list_move_tail() instead of list_del() + list_add_tail().
>
> Reported-by: Hulk Robot <hulkci@...wei.com>
> Signed-off-by: Baokun Li <libaokun1@...wei.com>
> ---
> fs/btrfs/send.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/fs/btrfs/send.c b/fs/btrfs/send.c
> index bd69db72acc5..a0e51b2416a1 100644
> --- a/fs/btrfs/send.c
> +++ b/fs/btrfs/send.c
> @@ -2083,8 +2083,7 @@ static struct name_cache_entry *name_cache_search(struct send_ctx *sctx,
> */
> static void name_cache_used(struct send_ctx *sctx, struct name_cache_entry *nce)
> {
> - list_del(&nce->list);
> - list_add_tail(&nce->list, &sctx->name_cache_list);
> + list_move_tail(&nce->list, &sctx->name_cache_list);
> }
Looks good.
You can consider open-code name_cache_used() as there is only one user.
Thanks, Anand
> /*
>
Powered by blists - more mailing lists