lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 8 Jun 2021 16:12:33 +0200
From:   David Sterba <dsterba@...e.cz>
To:     Anand Jain <anand.jain@...cle.com>
Cc:     Baokun Li <libaokun1@...wei.com>, linux-kernel@...r.kernel.org,
        Chris Mason <clm@...com>, Josef Bacik <josef@...icpanda.com>,
        David Sterba <dsterba@...e.com>, weiyongjun1@...wei.com,
        yuehaibing@...wei.com, yangjihong1@...wei.com, yukuai3@...wei.com,
        linux-btrfs@...r.kernel.org, kernel-janitors@...r.kernel.org,
        Hulk Robot <hulkci@...wei.com>
Subject: Re: [PATCH -next] btrfs: send: use list_move_tail instead of
 list_del/list_add_tail

On Tue, Jun 08, 2021 at 01:16:21PM +0800, Anand Jain wrote:
> On 8/6/21 11:12 am, Baokun Li wrote:
> > Using list_move_tail() instead of list_del() + list_add_tail().
> > 
> > Reported-by: Hulk Robot <hulkci@...wei.com>
> > Signed-off-by: Baokun Li <libaokun1@...wei.com>
> > ---
> >   fs/btrfs/send.c | 3 +--
> >   1 file changed, 1 insertion(+), 2 deletions(-)
> > 
> > diff --git a/fs/btrfs/send.c b/fs/btrfs/send.c
> > index bd69db72acc5..a0e51b2416a1 100644
> > --- a/fs/btrfs/send.c
> > +++ b/fs/btrfs/send.c
> > @@ -2083,8 +2083,7 @@ static struct name_cache_entry *name_cache_search(struct send_ctx *sctx,
> >    */
> >   static void name_cache_used(struct send_ctx *sctx, struct name_cache_entry *nce)
> >   {
> > -	list_del(&nce->list);
> > -	list_add_tail(&nce->list, &sctx->name_cache_list);
> > +	list_move_tail(&nce->list, &sctx->name_cache_list);
> >   }
> 
> 
>   Looks good.
>   You can consider open-code name_cache_used() as there is only one user.

Yeah sounds like a good idea, with part of the function comment next to
the list_move_tail.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ