[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <d9226f4349c445c6ca63dc632b29e3e0@codeaurora.org>
Date: Wed, 16 Jun 2021 14:33:04 +0530
From: Sai Prakash Ranjan <saiprakash.ranjan@...eaurora.org>
To: Robin Murphy <robin.murphy@....com>
Cc: Krishna Reddy <vdumpa@...dia.com>, linux-arm-msm@...r.kernel.org,
linux-kernel@...r.kernel.org, iommu@...ts.linux-foundation.org,
Will Deacon <will@...nel.org>,
linux-arm-kernel@...ts.infradead.org,
Thierry Reding <treding@...dia.com>
Subject: Re: [PATCH] iommu/io-pgtable-arm: Optimize partial walk flush for
large scatter-gather list
On 2021-06-16 12:28, Sai Prakash Ranjan wrote:
> Hi Robin,
>
> On 2021-06-15 19:23, Robin Murphy wrote:
>> On 2021-06-15 12:51, Sai Prakash Ranjan wrote:
>
> <snip>...
>
>>> Hi @Robin, from these discussions it seems they are not ok with the
>>> change
>>> for all SoC vendor implementations and do not have any data on such
>>> impact.
>>> As I mentioned above, on QCOM platforms we do have several
>>> optimizations in HW
>>> for TLBIs and would like to make use of it and reduce the unmap
>>> latency.
>>> What do you think, should this be made implementation specific?
>>
>> Yes, it sounds like there's enough uncertainty for now that this needs
>> to be an opt-in feature. However, I still think that non-strict mode
>> could use it generically, since that's all about over-invalidating to
>> save time on individual unmaps - and relatively non-deterministic -
>> already.
>>
>> So maybe we have a second set of iommu_flush_ops, or just a flag
>> somewhere to control the tlb_flush_walk functions internally, and the
>> choice can be made in the iommu_get_dma_strict() test, but also forced
>> on all the time by your init_context hook. What do you reckon?
>>
>
> Sounds good to me. Since you mentioned non-strict mode using it
> generically,
> can't we just set tlb_flush_all() in io_pgtable_tlb_flush_walk() like
> below
> based on quirk so that we don't need to add any check in
> iommu_get_dma_strict()
> and just force the new flush_ops in init_context hook?
>
> if (iop->cfg.quirks & IO_PGTABLE_QUIRK_NON_STRICT) {
> iop->cfg.tlb->tlb_flush_all(iop->cookie);
> return;
> }
>
Instead of flush_ops in init_context hook, perhaps a io_pgtable quirk
since this
is related to tlb, probably a bad name but IO_PGTABLE_QUIRK_TLB_INV
which will be
set in init_context impl hook and the prev condition in
io_pgtable_tlb_flush_walk()
becomes something like below. Seems very minimal and neat instead of
poking into
tlb_flush_walk functions or touching dma strict with some flag?
if (iop->cfg.quirks & IO_PGTABLE_QUIRK_NON_STRICT ||
iop->cfg.quirks & IO_PGTABLE_QUIRK_TLB_INV) {
iop->cfg.tlb->tlb_flush_all(iop->cookie);
return;
}
Thanks,
Sai
--
QUALCOMM INDIA, on behalf of Qualcomm Innovation Center, Inc. is a
member
of Code Aurora Forum, hosted by The Linux Foundation
Powered by blists - more mailing lists