[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <YQFY5/cq2thyHzUe@infradead.org>
Date: Wed, 28 Jul 2021 14:17:27 +0100
From: Christoph Hellwig <hch@...radead.org>
To: Tom Lendacky <thomas.lendacky@....com>
Cc: linux-kernel@...r.kernel.org, x86@...nel.org,
linuxppc-dev@...ts.ozlabs.org, linux-s390@...r.kernel.org,
iommu@...ts.linux-foundation.org, kvm@...r.kernel.org,
linux-efi@...r.kernel.org, platform-driver-x86@...r.kernel.org,
linux-graphics-maintainer@...are.com,
amd-gfx@...ts.freedesktop.org, dri-devel@...ts.freedesktop.org,
kexec@...ts.infradead.org, linux-fsdevel@...r.kernel.org,
Andi Kleen <ak@...ux.intel.com>,
Tianyu Lan <Tianyu.Lan@...rosoft.com>,
Borislav Petkov <bp@...en8.de>,
Brijesh Singh <brijesh.singh@....com>
Subject: Re: [PATCH 01/11] mm: Introduce a function to check for
virtualization protection features
On Tue, Jul 27, 2021 at 05:26:04PM -0500, Tom Lendacky via iommu wrote:
> In prep for other protected virtualization technologies, introduce a
> generic helper function, prot_guest_has(), that can be used to check
> for specific protection attributes, like memory encryption. This is
> intended to eliminate having to add multiple technology-specific checks
> to the code (e.g. if (sev_active() || tdx_active())).
So common checks obviously make sense, but I really hate the stupid
multiplexer. Having one well-documented helper per feature is much
easier to follow.
> +#define PATTR_MEM_ENCRYPT 0 /* Encrypted memory */
> +#define PATTR_HOST_MEM_ENCRYPT 1 /* Host encrypted memory */
> +#define PATTR_GUEST_MEM_ENCRYPT 2 /* Guest encrypted memory */
> +#define PATTR_GUEST_PROT_STATE 3 /* Guest encrypted state */
The kerneldoc comments on these individual helpers will give you plenty
of space to properly document what they indicate and what a (potential)
caller should do based on them. Something the above comments completely
fail to.
Powered by blists - more mailing lists