[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <d8d1837a-583b-3926-5057-755acc84a5c9@gmail.com>
Date: Tue, 3 Aug 2021 20:40:10 +0200
From: Maximilian Luz <luzmaximilian@...il.com>
To: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>,
Hans de Goede <hdegoede@...hat.com>,
platform-driver-x86@...r.kernel.org, linux-kernel@...r.kernel.org
Cc: Mark Gross <mgross@...ux.intel.com>
Subject: Re: [PATCH v1 1/1] platform/surface: aggregator: Ouse y instead of
objs in Makefile
On 8/3/21 7:50 PM, Andy Shevchenko wrote:
> The 'objs' is for user space tools, for the kernel modules
> we should use 'y'.
>
> Signed-off-by: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
Thank you! I was previously not aware of that distinction. Two small
notes:
- There is a typo in the subject line.
- With that change, the ifeq could be placed in-line (see note below).
All in all looks good to me (assuming the typo gets fixed).
Reviewed-by: Maximilian Luz <luzmaximilian@...il.com>
> ---
> drivers/platform/surface/aggregator/Makefile | 12 ++++++------
> 1 file changed, 6 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/platform/surface/aggregator/Makefile b/drivers/platform/surface/aggregator/Makefile
> index c8498c41e758..ce548dba1d4b 100644
> --- a/drivers/platform/surface/aggregator/Makefile
> +++ b/drivers/platform/surface/aggregator/Makefile
> @@ -6,12 +6,12 @@ CFLAGS_core.o = -I$(src)
>
> obj-$(CONFIG_SURFACE_AGGREGATOR) += surface_aggregator.o
>
> -surface_aggregator-objs := core.o
> -surface_aggregator-objs += ssh_parser.o
> -surface_aggregator-objs += ssh_packet_layer.o
> -surface_aggregator-objs += ssh_request_layer.o
> -surface_aggregator-objs += controller.o
> +surface_aggregator-y := core.o
> +surface_aggregator-y += ssh_parser.o
> +surface_aggregator-y += ssh_packet_layer.o
> +surface_aggregator-y += ssh_request_layer.o
> +surface_aggregator-y += controller.o
>
> ifeq ($(CONFIG_SURFACE_AGGREGATOR_BUS),y)
> -surface_aggregator-objs += bus.o
> +surface_aggregator-y += bus.o
> endif
I believe it should now be possible to write this as
surface_aggregator-$(CONFIG_SURFACE_AGGREGATOR_BUS) += bus.o
which might be a bit cleaner. Don't have much of a preference though so
I'd also be fine with keeping the ifeq.
Regards,
Max
Powered by blists - more mailing lists