lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 6 Aug 2021 15:01:00 +0800
From:   Zeng Guang <guang.zeng@...el.com>
To:     Sean Christopherson <seanjc@...gle.com>
Cc:     Paolo Bonzini <pbonzini@...hat.com>,
        Vitaly Kuznetsov <vkuznets@...hat.com>,
        Wanpeng Li <wanpengli@...cent.com>,
        Jim Mattson <jmattson@...gle.com>,
        Joerg Roedel <joro@...tes.org>,
        "kvm@...r.kernel.org" <kvm@...r.kernel.org>,
        Dave Hansen <dave.hansen@...ux.intel.com>,
        "Luck, Tony" <tony.luck@...el.com>,
        Kan Liang <kan.liang@...ux.intel.com>,
        Thomas Gleixner <tglx@...utronix.de>,
        Ingo Molnar <mingo@...hat.com>, Borislav Petkov <bp@...en8.de>,
        "H. Peter Anvin" <hpa@...or.com>,
        Kim Phillips <kim.phillips@....com>,
        Jarkko Sakkinen <jarkko@...nel.org>,
        Jethro Beekman <jethro@...tanix.com>,
        "Huang, Kai" <kai.huang@...el.com>,
        "x86@...nel.org" <x86@...nel.org>,
        "linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
        "Hu, Robert" <robert.hu@...el.com>,
        "Gao, Chao" <chao.gao@...el.com>,
        Robert Hoo <robert.hu@...ux.intel.com>
Subject: Re: [PATCH v3 2/6] KVM: VMX: Extend BUILD_CONTROLS_SHADOW macro to
 support 64-bit variation

On 8/6/2021 6:32 AM, Sean Christopherson wrote:
> On Thu, Aug 05, 2021, Zeng Guang wrote:
>> From: Robert Hoo <robert.hu@...ux.intel.com>
>>
>> The Tertiary VM-Exec Control, different from previous control fields, is 64
>> bit. So extend BUILD_CONTROLS_SHADOW() by adding a 'bit' parameter, to
>> support both 32 bit and 64 bit fields' auxiliary functions building.
>> Also, define the auxiliary functions for Tertiary control field here, using
>> the new BUILD_CONTROLS_SHADOW().
>>
>> Suggested-by: Sean Christopherson <seanjc@...gle.com>
>> Signed-off-by: Robert Hoo <robert.hu@...ux.intel.com>
>> ---
>>   arch/x86/kvm/vmx/vmx.h | 23 ++++++++++++-----------
>>   1 file changed, 12 insertions(+), 11 deletions(-)
>>
>> diff --git a/arch/x86/kvm/vmx/vmx.h b/arch/x86/kvm/vmx/vmx.h
>> index 3979a947933a..945c6639ce24 100644
>> --- a/arch/x86/kvm/vmx/vmx.h
>> +++ b/arch/x86/kvm/vmx/vmx.h
>> @@ -413,31 +413,32 @@ static inline u8 vmx_get_rvi(void)
>>   	return vmcs_read16(GUEST_INTR_STATUS) & 0xff;
>>   }
>>   
>> -#define BUILD_CONTROLS_SHADOW(lname, uname)				    \
>> -static inline void lname##_controls_set(struct vcpu_vmx *vmx, u32 val)	    \
>> +#define BUILD_CONTROLS_SHADOW(lname, uname, bits)			    \
>> +static inline void lname##_controls_set(struct vcpu_vmx *vmx, u##bits val) \
> Align the trailing backslashes (with tabs when possible).  It's a lot of unfortunate
> churn, but it really does make the code easier to read.  An alternative is to split
> "static inline" to a separate line.
>
>>   {									    \
>>   	if (vmx->loaded_vmcs->controls_shadow.lname != val) {		    \
>> -		vmcs_write32(uname, val);				    \
>> +		vmcs_write##bits(uname, val);				    \
>>   		vmx->loaded_vmcs->controls_shadow.lname = val;		    \
>>   	}								    \
>>   }									    \
>> -static inline u32 lname##_controls_get(struct vcpu_vmx *vmx)		    \
>> +static inline u##bits lname##_controls_get(struct vcpu_vmx *vmx)	    \
>>   {									    \
>>   	return vmx->loaded_vmcs->controls_shadow.lname;			    \
>>   }									    \
>> -static inline void lname##_controls_setbit(struct vcpu_vmx *vmx, u32 val)   \
>> +static inline void lname##_controls_setbit(struct vcpu_vmx *vmx, u##bits val)   \
>>   {									    \
>>   	lname##_controls_set(vmx, lname##_controls_get(vmx) | val);	    \
>>   }									    \
>> -static inline void lname##_controls_clearbit(struct vcpu_vmx *vmx, u32 val) \
>> +static inline void lname##_controls_clearbit(struct vcpu_vmx *vmx, u##bits val) \
>>   {									    \
>>   	lname##_controls_set(vmx, lname##_controls_get(vmx) & ~val);	    \
>>   }
>> -BUILD_CONTROLS_SHADOW(vm_entry, VM_ENTRY_CONTROLS)
>> -BUILD_CONTROLS_SHADOW(vm_exit, VM_EXIT_CONTROLS)
>> -BUILD_CONTROLS_SHADOW(pin, PIN_BASED_VM_EXEC_CONTROL)
>> -BUILD_CONTROLS_SHADOW(exec, CPU_BASED_VM_EXEC_CONTROL)
>> -BUILD_CONTROLS_SHADOW(secondary_exec, SECONDARY_VM_EXEC_CONTROL)
>> +BUILD_CONTROLS_SHADOW(vm_entry, VM_ENTRY_CONTROLS, 32)
>> +BUILD_CONTROLS_SHADOW(vm_exit, VM_EXIT_CONTROLS, 32)
>> +BUILD_CONTROLS_SHADOW(pin, PIN_BASED_VM_EXEC_CONTROL, 32)
>> +BUILD_CONTROLS_SHADOW(exec, CPU_BASED_VM_EXEC_CONTROL, 32)
>> +BUILD_CONTROLS_SHADOW(secondary_exec, SECONDARY_VM_EXEC_CONTROL, 32)
>> +BUILD_CONTROLS_SHADOW(tertiary_exec, TERTIARY_VM_EXEC_CONTROL, 64)
> This fails to compile because all the TERTIARY collateral is in a later patch.


Alternative to derive relative TERTIARY collateral and prepare them in 
this patch. Ok for that ?

>
> I think I'd also prefer hiding the 32/64 param via more macros, e.g.
>
> #define __BUILD_CONTROLS_SHADOW(lname, uname, bits)				\
> static inline void lname##_controls_set(struct vcpu_vmx *vmx, u##bits val)	\
> {										\
> 	if (vmx->loaded_vmcs->controls_shadow.lname != val) {			\
> 		vmcs_write##bits(uname, val);					\
> 		vmx->loaded_vmcs->controls_shadow.lname = val;			\
> 	}									\
> }										\
> static inline u##bits lname##_controls_get(struct vcpu_vmx *vmx)		\
> {										\
> 	return vmx->loaded_vmcs->controls_shadow.lname;				\
> }										\
> static inline void lname##_controls_setbit(struct vcpu_vmx *vmx, u##bits val)	\
> {										\
> 	lname##_controls_set(vmx, lname##_controls_get(vmx) | val);		\
> }										\
> static inline void lname##_controls_clearbit(struct vcpu_vmx *vmx, u##bits val)	\
> {										\
> 	lname##_controls_set(vmx, lname##_controls_get(vmx) & ~val);		\
> }
> #define BUILD_CONTROLS_SHADOW(lname, uname)   __BUILD_CONTROLS_SHADOW(lname, uname, 32)
> #define BUILD_CONTROLS_SHADOW64(lname, uname) __BUILD_CONTROLS_SHADOW(lname, uname, 64)

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ