lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 14 Oct 2021 22:14:09 -0400
From:   Steven Rostedt <rostedt@...dmis.org>
To:     Yafang Shao <laoar.shao@...il.com>
Cc:     Kees Cook <keescook@...omium.org>,
        Mathieu Desnoyers <mathieu.desnoyers@...icios.com>,
        acme <acme@...nel.org>,
        kernel test robot <oliver.sang@...el.com>,
        0day robot <lkp@...el.com>, Petr Mladek <pmladek@...e.com>,
        Peter Zijlstra <peterz@...radead.org>,
        Alexander Viro <viro@...iv.linux.org.uk>,
        linux-kernel <linux-kernel@...r.kernel.org>,
        lkp <lkp@...ts.01.org>,
        Andrew Morton <akpm@...ux-foundation.org>,
        Valentin Schneider <valentin.schneider@....com>,
        Qiang Zhang <qiang.zhang@...driver.com>,
        robdclark <robdclark@...omium.org>,
        christian <christian@...uner.io>,
        Dietmar Eggemann <dietmar.eggemann@....com>,
        Ingo Molnar <mingo@...hat.com>,
        Juri Lelli <juri.lelli@...hat.com>,
        Vincent Guittot <vincent.guittot@...aro.org>,
        Ben Segall <bsegall@...gle.com>, Mel Gorman <mgorman@...e.de>,
        bristot <bristot@...hat.com>,
        aubrey li <aubrey.li@...ux.intel.com>,
        yu c chen <yu.c.chen@...el.com>
Subject: Re: [sched.h] 317419b91e:
 perf-sanity-tests.Parse_sched_tracepoints_fields.fail

On Fri, 15 Oct 2021 10:05:56 +0800
Yafang Shao <laoar.shao@...il.com> wrote:

> > I'd say we need a TASK_COMM_LEN_V1 to use in all the old hard-coded
> > places.
> >  
> 
> Sure, it will be easy to grep then.

Just because I'm picky about my bikeshed colors...


Perhaps have it called TASK_COMM_LEN_16 ?

The reason being, I have no idea what "V1" is. Version 1? What's that
mean? And now TASK_COMM_LEN can be either 16 or 24. Perhaps we can have
it be:

#define TASK_COMM_LEN_16	16
#define TASK_COMM_LEN_24	24

if CONFIG_BASE_SMALL
#define TASK_COMM_LEN			TASK_COMM_LEN_16
#else
#define TASK_COMM_LEN			TASK_COMM_LEN_24
#endif

or call it TASK_COMM_LEN_SMALL and TASK_COMM_LEN_LARGE

??

It's still "grepable"

-- Steve

Powered by blists - more mailing lists